Dashboard Illumination gone weird! - Renault Forums :: Independent Renault forum

Electronics In Car Entertainment (ICE), Sat-Nav, lighting, wiring etc.

LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 23rd January 2007 Thread Starter
james.sealey's Avatar
Join Date: Nov 2006
Posts: 37
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Dashboard Illumination gone weird!

Hi Guys

Recently my dashboard illumination has been acting a bit weird. With the ignition on, and my headlights and side lights off, everything is fine, the radio display and door/tyre display are illuminated as per normal.

HOWEVER, when I turn my headlights on, the full dashboard instantly lights up and then fades to almost being off within about a second, including the radio and door/tyre displays.

I can then be driving along and randomly the dashboard lights up to its normal itensity again and is usually fine for a while!

I have tried adjusting the illumination control to see if there was a bad contact, and tried a few enthusiastic taps and thumps at various points on the dash to see if there are any loose connections.

Anyone have any ideas?! I'm totally baffled other than coming to the conclusion the 'controller' for the dashboard lighting must be faulty and therefore in need of replacement.
Currently in james.sealey's garage:
2002 Renault Laguna II 1.8 16V
james.sealey is offline  
  5 Lastest Threads by james.sealey
Thread Forum Last Poster Replies Views Last Post
Is it me or are Lagunas the most expensive... Wheels & tyres daveyboy58 17 2892 6th November 2008 12:41 PM
Unusual spoiler on my 02 Laguna? Bodywork afur 30 7224 9th April 2008 06:37 PM
Oh dear..... crunch! Cars & motoring madnoel10 18 2319 26th August 2007 05:23 PM
Electric Window Mechanism Electronics superbiatch 1 1146 30th April 2007 07:26 PM
Dashboard Illumination gone weird! Electronics Lagdti 3 1397 23rd January 2007 04:33 PM
Sponsored Links
post #2 of 4 (permalink) Old 23rd January 2007
RIP 31-12-2008
leroy's Avatar
Join Date: Jan 2006
Posts: 5,807
Nominated 0 Times in 3 Posts
Nominated TOTW/F/M Award(s): 3
Thanks: 0
Thanked 10 Times in 5 Posts
Thumbs up Welcome

Hi there james and welcome to Renault Forums, hopefully one of the techguys will give you some advice soon
Regards Leroy

Beauty is in the eye of the Beerholder
Currently in leroy's garage:
2000W Renault Laguna Monaco 2.0L. F4R
leroy is offline  
post #3 of 4 (permalink) Old 23rd January 2007
Let's be carefull out there
chris m's Avatar
Join Date: Jan 2006
Posts: 19,344
Nominated 1 Time in 1 Post
Nominated TOTW/F/M Award(s): 3
Thanks: 3
Thanked 32 Times in 32 Posts
Send a message via MSN to chris m
welcome to the forums
Currently in chris m's garage:
2000 Scenic 2.0 16v Monaco, BMW 3 Series, Pug 206
chris m is offline  
post #4 of 4 (permalink) Old 23rd January 2007
Veteran Member
Technical Supremo
Lagdti's Avatar
Join Date: Dec 2005
Posts: 40,429
Nominated 2 Times in 20 Posts
Nominated TOTW/F/M Award(s): 18
Thanks: 149
Thanked 1,103 Times in 942 Posts
It does sound as though the controller is at fault.

I'm not sure about the Lag 2,but the Lag 1 uses a variable resistor to control the lighting brightness and it is easily by-passed to confirm that it is faulty.

I'd rather push my Alfa than drive a BMW....
Currently in Lagdti's garage:
2004 Saab 9-5 HOT Aero and a 2001 Audi A3 1.8 Turbo
Lagdti is offline  

dashboard , illumination , weird

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome