Megane - Convertable - please please help - Page 2 - Renault Forums :: Independent Renault forum

Electronics In Car Entertainment (ICE), Sat-Nav, lighting, wiring etc.

LinkBack Thread Tools Display Modes
post #6 of 8 (permalink) Old 4th February 2007 Thread Starter
Junior Member
Join Date: Feb 2007
Posts: 6
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
problem with megane

hi thanks in my manual the light looks like a engin with a fan at the front and a stop sign within the engin logo i had the cam belt done about 6 months ago do u think this could be the problem and if so how do they combine and why would it keep cutting out the car cheers i also had the fuel pump changed would this cas anything too cheers jay
Currently in rsturbo27's garage:
RENAULT megan 2.0idc sport convertable
rsturbo27 is offline  
Sponsored Links
post #7 of 8 (permalink) Old 9th July 2008
Junior Member
Join Date: Sep 2007
Posts: 2
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Hey people, iv got a megane 225 and the same thing happend to mine, at first the engine managment light kept comming on then while on the motorway it would go into limp mode (wont go over 30mph) when you switch the engine back on and off it starts working normal again. iv tryd everything from new plugs from the main dealers (which aint cheap 15+VAT each) to new coils , messed around with the boost settings and still no luck. its going in tomorw for a compression test to see weather theres a damaged valve and if there is still no luck its going straight back to the main dealers to be put on diagnostic machine. if i find the problem with mine i would post a thread with the code as i know there are other renaults that have the same fault.
Currently in Sporty2442's garage:
Megane 225 sport 5dr
Sporty2442 is offline  
post #8 of 8 (permalink) Old 12th October 2009
Junior Member
Join Date: Oct 2009
Posts: 2
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
had the same problem a few months ago it turned out to be the fuel pressure sensor cost me a fortune lasted a few days and went again benn replaced twice now i have a wiring fault still isn't running 3 months later deep joy gonna get me a vauhall lol
bjmdjuk is offline  

convertable , megane

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome