ABS Relay Laguna Sports dti 2000 - Page 2 - Renault Forums :: Independent Renault forum

Electronics In Car Entertainment (ICE), Sat-Nav, lighting, wiring etc.

LinkBack Thread Tools Display Modes
post #6 of 10 (permalink) Old 27th March 2007
Junior Member
Join Date: Jan 2007
Posts: 12
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Hi (posted this in electronics section)

My abs stopped working a few weeks ago and had STOP,SERV,Handbrake and ABS lights on.

I have spend the last two weeks searching for information on the system and how to fix it.

After paying a garage 45 for codes to be read, they said power relay fault and would probably need new unit at 500 plus labour.....not likely as the cars only worth 1.5k at best.

I took the ABS controller out (Teves MK20i), easier than it looks and spent the last week fixing it. You can still drive without the abs ECU as the brake circuit is sealed.

Took me 1 day to get inside the thing (well sealed), not a power relay in sight (all done with power mosfets). Found the fault easy, bad connection on power pins, resoldered all connections and the stop light went out on the bench but still had abs light.

After a week of searching for info on reading codes from it, found out that all you have to do is simulate driving above 12 mph and the damn light went out.

So in conclusion :-


Power fault on pins 3 or 4 or blown fuse F18/F24.


Bad connection at abs ECU on multiplug ( bugger to disconnect )

ABS/SERV lights can be lots of different problems :-

Fuse F9/F10 blown or bad connection (these are 30A in the engine comp)

Wheel sensor open circuit/dirty

Pump open circuit

Solenoid open circuit (can only be checked by opening ecu )

Internal track fault as mine was (again, can only be found by opening)

When you have the unit disconnected, quite easy to check some of above and find the probable cause.

Hope this helps someone else avoid costly rip off......
Currently in stevedrink's garage:
2000 Laguna I 1.9DTi
stevedrink is offline  
Sponsored Links
post #7 of 10 (permalink) Old 27th March 2007
Junior Member
Join Date: Jan 2007
Posts: 12
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Also what year is you car ?

Check fuses first, check the connections are clean. If F14 (5A) or F18 (15A) are blown this will give your lights. The other fuses cause just ABS light but worth a look anyway.

Mine had newer type abs controller on 2000 dti. Yours may have relays.

To check the type, remove main cover, remove wheel arch splash cover on front pass side, remove small front left splash cover (uses one of the same screws as wheel arch cover.

Jack up the car and support on stand. Lie on back and slide between wheel and front bumper to see it properly, the back of the abs controller is visible through wheel arch if you want a look before going under.

Mine looked like this one,see attchment. The picture shows a volvo one but it's the same on mine.

If yours is like mine, I can probably guide you to a resolution, even if it's an old one, we should be able to sort it.
Attached Thumbnails
Click image for larger version

Name:	ABS_Volvo_2.gif
Views:	23
Size:	25.7 KB
ID:	2681  
Currently in stevedrink's garage:
2000 Laguna I 1.9DTi

Last edited by stevedrink; 27th March 2007 at 09:50 PM.
stevedrink is offline  
post #8 of 10 (permalink) Old 27th March 2007
Veteran Member
Technical Supremo
Lagdti's Avatar
Join Date: Dec 2005
Posts: 40,429
Nominated 2 Times in 20 Posts
Nominated TOTW/F/M Award(s): 18
Thanks: 149
Thanked 1,103 Times in 942 Posts
This is great stuff!.

Excellent info Stevedrink,keep it coming.

I'd rather push my Alfa than drive a BMW....
Currently in Lagdti's garage:
2004 Saab 9-5 HOT Aero and a 2001 Audi A3 1.8 Turbo
Lagdti is offline  
post #9 of 10 (permalink) Old 27th March 2007
Diamond member
fig_jam_uk's Avatar
Join Date: Jul 2006
Posts: 669
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to fig_jam_uk
Good info there

Currently in fig_jam_uk's garage:
98 1.6 16v Laguna Sport.
fig_jam_uk is offline  
post #10 of 10 (permalink) Old 28th March 2007
Platinum member
bonedavid's Avatar
Join Date: Jul 2005
Posts: 1,929
Nominated 0 Times in 1 Post
Nominated TOTW/F/M Award(s): 1
Thanks: 0
Thanked 11 Times in 4 Posts
thanks for the great info Steve...thread moved to electronics forum
Currently in bonedavid's garage:
women wild
bonedavid is offline  

abs , dti , laguna , relay , sports

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome