laguna warning lights help!!! - Page 2 - Renault Forums :: Independent Renault forum

Electronics In Car Entertainment (ICE), Sat-Nav, lighting, wiring etc.

LinkBack Thread Tools Display Modes
post #6 of 8 (permalink) Old 5th September 2007
Junior Member
Join Date: Sep 2007
Posts: 1
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Same here

I have exactly the same problem with my 1998 Laguna 1.8 RN Family Estate. It started a couple of days ago. Got back from a 2 week holiday, car started first time, no warning lights. Got home, started it about 3 hours later and oil and temp (and STOP) warning lights stay on. The car runs fine and doesn't overheat and there's no oil loss.
I took it to my usual independent servicer who had a diagnostics specialist in today. The word is that it is a known dashboard earthing fault but as to where ... that's the tricky bit. I was going to try contacting my local Renault dealer to see if they had any useful inside info on locating the earth fault. What do you think they'll say (apart from "Bring it in and well spend a whole day looking and charge you mega-squids for the privilege")?

I'll let you know how I get on.

Currently in waynemorris's garage:
1998 Laguna 1 1.8 Family Estate
waynemorris is offline  
Sponsored Links
post #7 of 8 (permalink) Old 13th January 2008
Junior Member
Join Date: Jan 2007
Posts: 7
Nominated 0 Times in 4,294,967,295 Posts
Nominated TOTW/F/M Award(s): 1
Thanks: 0
Thanked 0 Times in 0 Posts
I have the same car as waynemorris and have just got the same fault, has anyone worked out how to solve this? Is it not a case of one sensor being faulty and the other coming on? it is a pain in the a**e!
Currently in windowlikkersbus's garage:
2000 renault laguna 2.0 16v rxe estate
windowlikkersbus is offline  
post #8 of 8 (permalink) Old 14th January 2008
Join Date: Jan 2007
Posts: 32
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
I also drive a V reg Laguna RXE. This one had instruments that were going crazy and the speedo and tacho were going up and down like a yoyo. and sometimes it all went dead but the car still drove fine. A bit different to yours as there no warning lights coming on.
I had the instrument panel out looking for bad earth or dry solder joints (found nothing) then refitted it and it was ok for a couple of days then the faults started again.
To cut a long story short I managed to get an instrument panel from someone breaking the same model on ebay . Paid him 30 and hey presto! All has been well with replacement instrument panel.
I would suggest considering replacing the instrument panel on yours. They have a reputation for going faulty.
Hope this helps.
Currently in Bernard's garage:
V reg Laguna 2.0 16v RXE and very nice too!
Bernard is offline  

laguna , lights , warning

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome