laguna 2 instrument cluster - Renault Forums :: Independent Renault forum

Electronics In Car Entertainment (ICE), Sat-Nav, lighting, wiring etc.

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 24th March 2007 Thread Starter
Junior Member
Join Date: Mar 2007
Posts: 7
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
laguna 2 instrument cluster

Hi, can anyone help me with my instrument cluster problem? I have read that people have had problems with this before but not sure if its the same one. whem i put my card in the instruments dont move. then as car warms up the instruments come on then off as if ive just put card in. eventually it settles and the cluster works fine. a friend of mine had the same prob. renault changed the cluster but it turned out to be a loose connection in battery area! think might be same on mine with a power supply problem, but have checked battery connections. fine. fuse box/relay compart in engine. fine. Could it be a loose connection at the back of the cluster, or is it more likely to be a component in cluster? also ABS light has just come on. MOT due end of month. renault lpool cant fit me in til 4th april. typical. any help greatly appreciated. thanks in advance. John.
Currently in scorchio's garage:
renault laguna II 1.8 dynamique 2001
scorchio is offline  
  5 Lastest Threads by scorchio
Thread Forum Last Poster Replies Views Last Post
laguna 2 ABS light Electronics snowdrop76 5 1589 21st May 2007 08:59 PM
laguna 2 instrument cluster Electronics chris m 1 943 24th March 2007 12:04 PM
Sponsored Links
post #2 of 2 (permalink) Old 24th March 2007
Let's be carefull out there
chris m's Avatar
Join Date: Jan 2006
Posts: 19,344
Nominated 1 Time in 1 Post
Nominated TOTW/F/M Award(s): 3
Thanks: 3
Thanked 32 Times in 32 Posts
Send a message via MSN to chris m
Welcome to the forum.
Currently in chris m's garage:
2000 Scenic 2.0 16v Monaco, BMW 3 Series, Pug 206
chris m is offline  

cluster , instrument , laguna

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome