Renault Megane - Rear Light And Rev Counter Fault - Page 2 - Renault Forums :: Independent Renault forum

Electronics In Car Entertainment (ICE), Sat-Nav, lighting, wiring etc.

LinkBack Thread Tools Display Modes
post #6 of 8 (permalink) Old 29th May 2007 Thread Starter
Junior Member
reading_royal's Avatar
Join Date: May 2007
Posts: 9
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
thanks guys for the help, i'll look into it this weekend and if i get anywhere i'll keep you posted.
Currently in reading_royal's garage:
1996 Renault Megane 1.6
reading_royal is offline  
Sponsored Links
post #7 of 8 (permalink) Old 27th March 2009
Junior Member
Join Date: Mar 2009
Posts: 1
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
hi ... im having a very similar problem. but the issue seems to be isolated to the drivers side and when the main lights are on.. the indicators seem to work ok when the lights are not turned on but strange things occur when the brake is pressed.. mainly the fog lamp illuminating on the dashboard which is how i realised there was an issue..

If i am correct there is an earth cable below the rear lights.. I have disconnected this and it doesnt seem to be corrected in any way at the connector. I have also checked all the bulbs and they appear in working order..

Any more ideas???

baggas is offline  
post #8 of 8 (permalink) Old 6th June 2009
Junior Member
Join Date: May 2006
Posts: 1
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Megane Rear Light Fault


I have been having problems with my O/S rear indicator for some time. When braking while indicating the brake light and indicator flash alternately.

This is a classic symptom of a poor earth on the lamp unit. The fault seems to be in the multi plug but the connectors are so small I wasn't able to improve the connection permanently.

I have just made a semi permanent cure using a piece of insulated cable with a small crocodile clip on each end.

Remove the lamp cover and remove the bulb holder by releasing the clip at each side.

Looking at the bulb holder from the bulb side you will see that the earth path is the strip of metal running around the outside of the indicator and across the top to the reverse lamp bulb. In the centre the strip is quite thin. I attached one of the crocodile clips on this and the other th the earth point on the body below the lamp unit. The connection in the multi plug is now bypassed and the problem is solved.

This repair may cure other types of strange behaviour in the rear lamps.

It would be better the attach the wire more permanently but I haven't yet worked this out. I don't think solder would take on the metal used on the bulb holder circuit.

I hope this is helpful.

Currently in grum's garage:
1999 Megane 1.6 Auto Hatchback
grum is offline  

counter , fault , light , megane , rear , renault , rev

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome