Renault Megane 1 - Speedo Not Working - Page 2 - Renault Forums :: Independent Renault forum

Electronics In Car Entertainment (ICE), Sat-Nav, lighting, wiring etc.

LinkBack Thread Tools Display Modes
post #6 of 7 (permalink) Old 29th July 2007
Veteran Member
Technical Supremo
Lagdti's Avatar
Join Date: Dec 2005
Posts: 40,429
Nominated 2 Times in 20 Posts
Nominated TOTW/F/M Award(s): 18
Thanks: 149
Thanked 1,103 Times in 942 Posts
Did you manage to fix it Brownjl?.

I'd rather push my Alfa than drive a BMW....
Currently in Lagdti's garage:
2004 Saab 9-5 HOT Aero and a 2001 Audi A3 1.8 Turbo
Lagdti is offline  
Sponsored Links
post #7 of 7 (permalink) Old 3rd August 2007
Junior Member
kbobkin4's Avatar
Join Date: Jan 2007
Posts: 11
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to kbobkin4
Smile Renault Megane 1 - Speedo Not Working

hi had the very same problem speedo stopped, tested everything checked all sensors etc then did a back trace from ECU cables in wiring loom and guess wot a broken cable located below the earth braid also an earth but for the ecu itself in fact 2 cables are crimped into 1 eyelet and one had broken out completely and the other was very close to doing the same these cables are located on the altenator side of the engine. trace the loom back from ECU to engine hopefully that is all your problem is fingers crossed..........
Currently in kbobkin4's garage:
1998 renault megane 1.6 classic alize
kbobkin4 is offline  

megane , renault , speedo , working

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome