Dashboard fualt? - Renault Forums :: Independent Renault forum

Electronics In Car Entertainment (ICE), Sat-Nav, lighting, wiring etc.

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 6th August 2007 Thread Starter
Junior Member
Join Date: Aug 2007
Posts: 2
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Question Dashboard fualt?

Hi all,
I've a Sagum dash in my Laguna thats had a fault for a while now, and i've had enough No matter what the temp the engine is at, the guage reads half way! Question is....is it the guage or the sensor?? There's two on the engine(Volvo 2ltr 16V), one on the thermostat housing(replaced) and the other on the block above the flywheel. I,ve tested the second of the two and found that when i disconnect it the temp drops to zero and if i earth it the temp goes back to half way instead of the "OH MY GOD-THE ENGINES GOING TO BLOW" warning level!! Therefore, i suspect the guage. Is there a cheap fix???
Also, is this all linked to the engine management as there has been a noticable increase in fuel consumption.

All help appreciated
Currently in Dangan's garage:
1998 Laguna I 2ltr 16v
Dangan is offline  
  5 Lastest Threads by Dangan
Thread Forum Last Poster Replies Views Last Post
Dashboard fualt? Electronics madnoel10 2 903 6th August 2007 03:32 PM
Laguna Intermitant flat spot Engines JUNIOR1910 3 1064 6th August 2007 03:19 PM
Sponsored Links
post #2 of 3 (permalink) Old 6th August 2007
Let's be carefull out there
chris m's Avatar
Join Date: Jan 2006
Posts: 19,344
Nominated 1 Time in 1 Post
Nominated TOTW/F/M Award(s): 3
Thanks: 3
Thanked 32 Times in 32 Posts
Send a message via MSN to chris m
The sensor on the stat housing is just for the rad fan I think.
Does the rest of the dash work ok?
Currently in chris m's garage:
2000 Scenic 2.0 16v Monaco, BMW 3 Series, Pug 206
chris m is offline  
post #3 of 3 (permalink) Old 6th August 2007
Technical Supremo

Join Date: Feb 2007
Posts: 42,935
Nominated 16 Times in 67 Posts
Nominated TOTW/F/M Award(s): 28
Thanks: 372
Thanked 5,199 Times in 4,711 Posts
I suspect the second temp., sensor is duff - not only will it give a faulty reading to the guage but fool the ECU into thinking the engine is always cold and increase the amount of fuel into the intake. Poor MPG would also be the result due to overfueling.
Currently in madnoel10's garage:
Honda Civic 1.4l
madnoel10 is offline  

dashboard , fualt

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome