Laguna 2 Electrical fault in wet - Renault Forums :: Independent Renault forum

Electronics In Car Entertainment (ICE), Sat-Nav, lighting, wiring etc.

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 21st August 2007 Thread Starter
Junior Member
Join Date: Aug 2007
Posts: 15
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 1
Thanked 0 Times in 0 Posts
Laguna 2 Electrical fault in wet

I have a Laguna 2 1.8 Privilege, for the last couple of months when it rains my abs light comes on and iut says theres a fault and its switched off, then after a while the light goes out, but this week as well as that happening the stereo and Climate control panels turn off and the stop light comes on for a few seconds then everything goes back to normal.

This only happens in the wet.

Any help appreciated thanks
monkeyjismtea is offline  
  5 Lastest Threads by monkeyjismtea
Thread Forum Last Poster Replies Views Last Post
Laguna 2/2 Tourer Brake Light Problem Electronics monkeyjismtea 1 1271 9th June 2010 08:22 AM
Battery Charge Fault Electronics monkeyjismtea 4 6228 3rd November 2007 06:54 AM
Laguna 2 Electrical fault in wet Electronics ottoman 2 1177 21st August 2007 12:07 AM
Sponsored Links
post #2 of 3 (permalink) Old 21st August 2007
Veteran Member
Technical Supremo
Fishing the Sea Champion
Donald's Avatar
Join Date: Oct 2006
Posts: 18,909
Nominated 1 Time in 1 Post
Nominated TOTW/F/M Award(s): 11
Thanks: 329
Thanked 205 Times in 161 Posts
Hi iam not that sure this is going to help but its worth a try,the abs sensor is in the hub and when its wet it should not matter as it is a sealed unit but what you could check is where its first connection is for working at the car or replacing it,if you follow the abs wire from the sensor to where it is first connected with the ignition off press and pull the connector and then reconnected to see if its just a bad connection,iam sorry i cant help with your other problems other than it sounds intermittent and could be a lose connection also iam sure other members will help soon, all the best Donald.
Currently in Donald's garage:
2005 Mercedes Benz C200 Classic SE Kompresser & 1998 Fiat Cinquecento Fire Sporting,some may say i could do far better?,i say i could do far worse.

Last edited by Donald; 21st August 2007 at 07:42 AM.
Donald is offline  
post #3 of 3 (permalink) Old 21st August 2007
Platinum member
Join Date: Aug 2005
Posts: 14,145
Nominated 2 Times in 3 Posts
Nominated TOTW/F/M Award(s): 3
Thanks: 0
Thanked 68 Times in 26 Posts
I would check you fuse boxes to see if any water penetration, Also around the Ecu etc on some Renaults it can be a problem and can be expensive if not rectified at an early stage.
ottoman is offline  

electrical , fault , laguna , wet

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome