speedometer fluctuting - Renault Forums :: Independent Renault forum

Electronics In Car Entertainment (ICE), Sat-Nav, lighting, wiring etc.

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 27th November 2007 Thread Starter
Junior Member
Join Date: Oct 2007
Posts: 5
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
speedometer fluctuting

i have a megane classic 1.4 RTL year of man ftr late 1999
The following have been checked or replaced
Both front wheel abs sensors instrument panel
and there is No sensor on the gearbox this is
driving !!! myself and my mechanic mad
Can anyone please help me
The only faulty readings are speedo indicatoe are moving wildly and mileage reading seems to reading higher
Many thanks
bluefredie is offline  
  5 Lastest Threads by bluefredie
Thread Forum Last Poster Replies Views Last Post
flutuating speedo Electronics Mike11 6 1330 4th February 2008 04:40 PM
speedometer fluctuting Electronics madnoel10 2 1059 27th November 2007 11:04 AM
speedo Electronics madnoel10 1 830 2nd November 2007 01:11 PM
bluefredie Electronics HZlatan 1 728 19th October 2007 12:21 PM
Sponsored Links
post #2 of 3 (permalink) Old 28th November 2007
Junior Member
Join Date: Jul 2007
Posts: 4
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Check the earth at the back of the engine block near to the dipstick. I had this problem with my Megane Classic 1.6 and it turned out that one of the 2 earth wires, that are earthed at this point, had corroded. When it was repaired the speedo worked perfectly.
Currently in Antian's garage:
Renault Megane Classic 1.6 RN
Antian is offline  
post #3 of 3 (permalink) Old 28th November 2007
Technical Supremo

Join Date: Feb 2007
Posts: 42,935
Nominated 16 Times in 67 Posts
Nominated TOTW/F/M Award(s): 28
Thanks: 371
Thanked 5,199 Times in 4,711 Posts
Hi Fredie - if your speedo works via the ABS system it could be one of the ABS sensor rings has split or come adrift - not uncommon I'm afraid. This would cause speedo fluctuation. Also check the teeth in the ring are clean and none missing.
Currently in madnoel10's garage:
Honda Civic 1.4l
madnoel10 is offline  

fluctuting , speedometer

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome