Snow Joke! - Renault Forums :: Independent Renault forum

Electronics In Car Entertainment (ICE), Sat-Nav, lighting, wiring etc.

LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 4th January 2008 Thread Starter
Junior Member
Join Date: Jan 2008
Posts: 1
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Snow Joke!

Hi - I own a 2006 Scenic 1.6 - great car no probs - until today!

On way to work some snow on the roof of the car slid down onto the windscreen. I switched on the wipers to clear the snow and heard a very expensive crack!

Took the car to my local Renault garage - 371 to repair!!!! Says it need a complete wiper unit at a cost of 218 + VAT!!

Anyone else come across a similar problem?

Needless to say I was

OK I know I probably should have cleared ALL the snow off the car before starting out, but surely in this day and age a wiper motor could deal with a wee bit of snow!!
Currently in oxters's garage:
2006 Scenic
oxters is offline  
  5 Lastest Threads by oxters
Thread Forum Last Poster Replies Views Last Post
Snow Joke! Electronics Tiggerz_SRi 3 820 4th January 2008 04:37 PM
Sponsored Links
post #2 of 4 (permalink) Old 4th January 2008
Platinum member
Join Date: Aug 2005
Posts: 14,145
Nominated 2 Times in 3 Posts
Nominated TOTW/F/M Award(s): 3
Thanks: 0
Thanked 68 Times in 26 Posts

I have never heard of this on a Scenic nor any other car.

A very expensive lesson learned
ottoman is offline  
post #3 of 4 (permalink) Old 4th January 2008
Technical Supremo

Join Date: Feb 2007
Posts: 42,941
Nominated 16 Times in 67 Posts
Nominated TOTW/F/M Award(s): 28
Thanks: 372
Thanked 5,201 Times in 4,712 Posts
Hi Oxters - gee whizz aren't shovels and brushes a terrible price nowadays (371 a piece) - only joking - if it were mine I would have a look at the wiper motor and linkage - could be a linkage has popped off and may well be able to be reconnected. Many garages nowadays just won't do repairs - anything to get the arm in. If you do get it replaced ask for the old component and then you could see why it failed.
Currently in madnoel10's garage:
Honda Civic 1.4l
madnoel10 is offline  
post #4 of 4 (permalink) Old 4th January 2008
Platinum member
Tiggerz_SRi's Avatar
Join Date: Dec 2007
Posts: 16,417
Nominated 0 Times in 0 Posts
Nominated TOTW/F/M Award(s): 2
Thanks: 2
Thanked 12 Times in 12 Posts
Send a message via MSN to Tiggerz_SRi
I'd get one from a renault breakers! Thats daylight robbery!
Currently in Tiggerz_SRi's garage:
Audi a4 v6 avant, used to have bmw 525d se estate, 2001 Toyota Previa 2.4 VVTi GLS, '98 R FORD Galaxy 2.3 Ghia X a Espace III 2.2dT RXE and a Lag I 1.8RT!
Tiggerz_SRi is offline  

joke , snow

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome