Electrical Fault or Water in the Diesel Light HELP! - Renault Forums :: Independent Renault forum

Electronics In Car Entertainment (ICE), Sat-Nav, lighting, wiring etc.

LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 15th January 2008 Thread Starter
Junior Member
Join Date: Jan 2008
Posts: 1
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Electrical Fault or Water in the Diesel Light HELP!

Hi All,

I took my car into the local garage to have a service and MOT and ever since it keeps coming up with the Electrical Fault or water in the diesel light. They also replaced the passenger side wish-bone joint

It only seems to appear when i hit 50mph , The car still drives ok and I don't notice any loss in performance. The light sometimes goes off and then comes back on again.

The garage did a "Download" and found nothing apparently! Inspecting the work there is a lot of oil that has leaked from the oil filter change. I have tired to clean it off as much as possible and this hasn't had any effect.

any other ideas? All suggestions appreciated!
Currently in andycapppp's garage:
1.5 DCI 100 Dynamic
andycapppp is offline  
  5 Lastest Threads by andycapppp
Thread Forum Last Poster Replies Views Last Post
Electrical Fault or Water in the Diesel Light... Electronics madnoel10 3 930 15th January 2008 09:58 PM
Sponsored Links
post #2 of 4 (permalink) Old 15th January 2008
ALLYZ66's Avatar
Join Date: Jan 2007
Posts: 75
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
hi,that light also can mean a problem with injectors/diesel pump but also i have had this light on my kangoo 1.5dci and it turned out to be a sensor plug,when getting a service someone disturbed it(this is quite easy to do i've found),try checking all the sensor plugs-there is three quite visable in the engine bay,1 on the injector pump,1 on the side of the air box and one ontop of the airbox,also check the plugs on the injectors.
Currently in ALLYZ66's garage:
RENAULT KANGOO 1.5DCI.and a MK2 escort 16 sport and a cooking oil powered isuzu crew cab pick up everywhere...
ALLYZ66 is offline  
post #3 of 4 (permalink) Old 17th January 2008
Diamond member
david geoghegan's Avatar
Join Date: Nov 2006
Posts: 167
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
it could be anything ,best bet is after you check the connectors on the sensors if not them you will have to get a diagnostic check done on it
Currently in david geoghegan's garage:
2004 renault laguna II 1.9dci
david geoghegan is offline  
post #4 of 4 (permalink) Old 17th January 2008
Technical Supremo

Join Date: Feb 2007
Posts: 42,935
Nominated 16 Times in 67 Posts
Nominated TOTW/F/M Award(s): 28
Thanks: 371
Thanked 5,199 Times in 4,711 Posts
Could be a duff or dirty EGR valve - also check the connections to the turbo pressure sensor and the tirbo solenoid
THen again maybe it telling the truth and there is water in the diesel - the filter can be drained as a check
Currently in madnoel10's garage:
Honda Civic 1.4l

Last edited by madnoel10; 17th January 2008 at 04:09 PM.
madnoel10 is offline  

diesel , electrical , fault , light , water

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome