Clock*Fixed* - Renault Forums :: Independent Renault forum

Electronics In Car Entertainment (ICE), Sat-Nav, lighting, wiring etc.

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 21st January 2008 Thread Starter
Junior Member
Join Date: Apr 2007
Posts: 10
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Post Clock*Fixed*


I have a 1995 Laguna RXE Auto 1998 cc and the clock and external temperature has suddenly stopped working or illuminating,also the on-board computer display has started to go off,sometimes it shows the left half the display then only the right side of the display.
any ideas what might be at fault,have tried the fuses but nothing has changed.

look forward to any replies

Michael_Keen is offline  
  5 Lastest Threads by Michael_Keen
Thread Forum Last Poster Replies Views Last Post
Renault Scenic Cars & motoring bugsb 1 604 3rd October 2011 07:15 AM
Laguna Dashboard,Clock,Radio Lights Electronics Sarge 5 2106 2nd February 2011 09:14 AM
Clock*Fixed* Electronics Michael_Keen 2 855 21st January 2008 12:41 PM
Lag 1 CD Changer location Electronics buccy 9 1357 28th April 2007 05:20 PM
Hello Welcome to RenaultForums chris m 4 642 28th April 2007 05:10 PM
Sponsored Links
post #2 of 3 (permalink) Old 21st January 2008
Veteran Member
Technical Supremo
Lagdti's Avatar
Join Date: Dec 2005
Posts: 40,429
Nominated 2 Times in 20 Posts
Nominated TOTW/F/M Award(s): 18
Thanks: 149
Thanked 1,103 Times in 942 Posts
The displays are back lit by bulbs,so I suspect they need changing.

Both are pretty straight foward to do,and there is a how to on removing the dash panel.The cover over the clock just unclips and you'll see the screws holding the clock in place.

If you take the bulbs to any decent motorfactor they will be able to match them up with new ones for you.
Currently in Lagdti's garage:
2004 Saab 9-5 HOT Aero and a 2001 Audi A3 1.8 Turbo
Lagdti is offline  
post #3 of 3 (permalink) Old 28th January 2008 Thread Starter
Junior Member
Join Date: Apr 2007
Posts: 10
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs up Clock

Hi lagdti

Thanks for the reply,done what you said and changed the bulbs,everything ok and works fine now,

many thanks

Michael_Keen is offline  


Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome