Renault Clio - Complete Electrical Failure - Renault Forums :: Independent Renault forum

Electronics In Car Entertainment (ICE), Sat-Nav, lighting, wiring etc.

LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 29th January 2008 Thread Starter
Junior Member
Join Date: Jan 2008
Posts: 1
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Renault Clio - Complete Electrical Failure


recentley my clio has been loseing power wen im driving,my lights go dim and no electrics work in the car. This does not happen all the time,at first i thought it was the battery so i brought a new battery but this still hasnt solved the problem!
When the problem acurs the engine also runs very strange and on tick over there is hardly any revs and nearly cuts out!!

just wondering if anyone had any ideas what this could be?? cheers
Currently in benny g's garage:
1998 clio RT
benny g is offline  
  5 Lastest Threads by benny g
Thread Forum Last Poster Replies Views Last Post
Renault Clio - Complete Electrical Failure Electronics dejan72 4 1828 29th January 2008 09:56 PM
Sponsored Links
post #2 of 5 (permalink) Old 29th January 2008
Platinum member
daft_plonk's Avatar
Join Date: Nov 2007
Posts: 4,955
Nominated 0 Times in 1 Post
Nominated TOTW/F/M Award(s): 3
Thanks: 0
Thanked 5 Times in 3 Posts
could be your alternator on its way out
Currently in daft_plonk's garage:
2003 Honda Civic Inspire S 1.6 Vtec
daft_plonk is offline  
post #3 of 5 (permalink) Old 29th January 2008
Banned User
Join Date: Dec 2007
Posts: 910
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 4 Times in 4 Posts
Send a message via MSN to swfcowl5
Could Be As Above But Have You Checked Alternator Wires Connected Tightly As Can Erode Or Come Loose Over Time Also When Was Last Service And What Was Done?
Currently in swfcowl5's garage:
Renault Megane 1998 RT 1.4i And A Renault Scenic 1.6 1998
swfcowl5 is offline  
post #4 of 5 (permalink) Old 30th January 2008
Veteran Member
Technical Supremo
Lagdti's Avatar
Join Date: Dec 2005
Posts: 40,429
Nominated 2 Times in 20 Posts
Nominated TOTW/F/M Award(s): 18
Thanks: 149
Thanked 1,103 Times in 942 Posts
Yep,could be alternator related,or it could be a loose battery terminal connection or a corroded/loose earth connection between the battery/body/engine somewhere.
Currently in Lagdti's garage:
2004 Saab 9-5 HOT Aero and a 2001 Audi A3 1.8 Turbo
Lagdti is offline  
post #5 of 5 (permalink) Old 1st February 2008
Diamond member
dejan72's Avatar
Join Date: Jun 2006
Posts: 405
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 5
Thanked 13 Times in 13 Posts
might be a diode plate in alternator if there's no warning light for battery.
Currently in dejan72's garage:
2002 laguna V6 24V
dejan72 is offline  

clio , complete , electrical , failure , renault

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome