mk 1 starting and battey charging problem - Renault Forums :: Independent Renault forum

Electronics In Car Entertainment (ICE), Sat-Nav, lighting, wiring etc.

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 18th February 2008 Thread Starter
Junior Member
Join Date: Feb 2008
Posts: 1
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
mk 1 starting and battey charging problem

im currently having problems with my clio. the problem started with the battery light showing we change the battery and replaced the alternator the battery is still loseing its charge and the car is cutting out and there is no power to start the car again. does anybody no wat the problem could be? thanks stig9167
stig9167 is offline  
  5 Lastest Threads by stig9167
Thread Forum Last Poster Replies Views Last Post
mk 1 starting and battey charging problem Electronics madnoel10 1 688 18th February 2008 12:37 PM
Sponsored Links
post #2 of 2 (permalink) Old 18th February 2008
Technical Supremo

Join Date: Feb 2007
Posts: 42,935
Nominated 16 Times in 67 Posts
Nominated TOTW/F/M Award(s): 28
Thanks: 372
Thanked 5,199 Times in 4,711 Posts
Have you checked the output of the alternator
Currently in madnoel10's garage:
Honda Civic 1.4l
madnoel10 is offline  

battey , charging , problem , starting

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome