1998 - no blow from the fan - Renault Forums :: Independent Renault forum

Electronics In Car Entertainment (ICE), Sat-Nav, lighting, wiring etc.

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 15th April 2008 Thread Starter
Junior Member
Macphil's Avatar
Join Date: Mar 2008
Posts: 25
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Hi Folks,

Having got my left indicator problem sorted out - thanks to Bob 925 - I am now looking for some help with the other problem I have at present. Mine is a 1998 1.6e RT Alize with air-con and the blower for air into the cabin doesn't work at all. I have heard of some only working on the 4th speed - but mine is totally dead (includes the 'other side' for recirculating air). The air con appears to work since the light comes on and there is a slight increase in revs but, because the blower won't work, no air comes out! There is warm and cold air coming in when the vents are open so it's heating / cooling OK.
I spoke to the mechanic who works on my cars and he suggested that the fuse may have blown because of a blocked pollen filter so I removed the cover, opened the pollen filter box and.... no filter inside! I have now replaced the filter element and checked the fuse (second up and second in from the right according to the diagram in the fuse cover). Fuse seems OK and I have taken the switch panel out of the dash and the cables are attached OK and the multiplug connector is a good fit.
I am thinking it could be the rotary switch itself that is faulty but I don't know how I could check it. I had thought of taking the switch out of my 1998 Scenic - but it doesn't have air-con so the switch gear is probably different.
At the moment this is the only problem with the car and I am perfectly happy with it otherwise, but the windows misting up inside can be dangerous and I am keen to get it sorted out.
Any ideas / suggestions would be most welcome.
Currently in Macphil's garage:
Renault Scenic 1.6 RT Sport (2000)

Last edited by Macphil; 18th April 2008 at 11:50 AM. Reason: should have been under 'heating' rather than 'electronics'
Macphil is offline  
  5 Lastest Threads by Macphil
Thread Forum Last Poster Replies Views Last Post
Newbie returns Welcome to RenaultForums dave_mezza2006 2 594 9th January 2012 11:14 PM
The Ducks Jokes & funny stuff wobbly spoon 1 614 2nd May 2008 12:57 AM
Visiting Grandpa Jokes & funny stuff harveydally 1 679 25th April 2008 11:46 PM
Trying to get your car up ramps? Cars & motoring Tiggerz_SRi 16 2265 22nd April 2008 11:04 PM
1998 - no blow from the fan Electronics delboy69 1 849 15th April 2008 11:09 PM
Sponsored Links
post #2 of 2 (permalink) Old 21st April 2008
Junior Member
delboy69's Avatar
Join Date: Apr 2008
Posts: 13
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
I'm having a similar problem - my blower is making the noise and the aircon lights come on BUT! no air comes out of the vents - it sounds like it should be and you can feel a slight waft of air but thats about it ( i 've farted more powerfully). Any ideas??

Update - Pollen Filter was choked with allsorts of crap. Just can't get the aircon to blow icy now
Currently in delboy69's garage:
2001 Renault Laguna 2 1.8 Dynamique

Last edited by delboy69; 2nd May 2008 at 10:34 PM. Reason: SORTED
delboy69 is offline  

blow , fan

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome