Renault clio 2003, ECU Problem? - Page 3 - Renault Forums :: Independent Renault forum

Electronics In Car Entertainment (ICE), Sat-Nav, lighting, wiring etc.

LinkBack Thread Tools Display Modes
post #11 of 11 (permalink) Old 4th August 2008
Veteran Member
Technical Supremo
Ralph's Avatar
Join Date: May 2008
Posts: 5,790
Nominated 2 Times in 8 Posts
Nominated TOTW/F/M Award(s): 4
Thanks: 118
Thanked 909 Times in 791 Posts
Funny enough a mate as just had the same problem
with a BMW M3 it cost him a Grand for a new ECU ,
so it's not just Renault that as a licence to print money.

Hope you get it sorted
Currently in Ralph's garage:
Clio 15 DCi 80, Kawasaki W800, Yamaha MT-07, LMS 5MT 3 1/2 inch Gauge.
Ralph is online now  
Sponsored Links

clio , ecu , problem , renault

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome