Vivaro ECU Pin out for CAMSHAFT sensor - Renault Forums :: Independent Renault forum

Electronics In Car Entertainment (ICE), Sat-Nav, lighting, wiring etc.

 6Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 41 (permalink) Old 4th September 2016 Thread Starter
Member
 
Join Date: Sep 2016
Posts: 33
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 6
Thanked 3 Times in 2 Posts
Unhappy Vivaro ECU Pin out for CAMSHAFT sensor

Hi peeps,

Vauxhall Vivaro 2010 2.0 CDTi M9R engine (same as Renault trafic)

Need the pinout for the Camshaft sensor at the ECU please?

My Van struggles to start but once started it runs like a dream, no smoke, no rattles, no odd noises, pulls with plenty of grunt with no flat spots.

Been a bit of a money pit so far,
Parts replaced so far:
NEW Camshaft Sensor
NEW Crank Sensor
Full Service
New Timing Chain kit and tensioner

Diagnostics done so far.
Sensors checked
Timing checked and chain renewed (Made no difference)
Scuttle drains cleaned and unblocked

Wiring allegedly checked but I want to check again as Renault Clip states DEF1 "NO SIGNAL" or P0340 on other code readers

Your help will be much appreciated.

I also have the Renault Clip and Timing Tools to lend to fellow members if and when required.
PS. Some members have stated that the Clip does not work on Vivaro's I can confirm that it works perfectly.
john86 is offline  
  5 Lastest Threads by john86
Thread Forum Last Poster Replies Views Last Post
ECU swap for 90bhp to 115bhp General tuning john86 0 370 16th September 2016 09:17 PM
Reflash Injection ECU Renault Trafic Electronics ours2012 4 393 15th September 2016 09:02 PM
Vivaro ECU Pin out for CAMSHAFT sensor Electronics Damien48 40 2829 4th September 2016 11:31 AM
Hello Welcome to RenaultForums john86 6 401 3rd September 2016 10:12 PM
Sponsored Links
Advertisement
 
post #2 of 41 (permalink) Old 4th September 2016
Veteran Member
Technical Supremo
 
ours2012's Avatar
 
Join Date: Dec 2014
Posts: 16,995
Nominated 41 Times in 35 Posts
Nominated TOTW/F/M Award(s): 12
Thanks: 1,804
Thanked 1,965 Times in 1,630 Posts
re: Vivaro ECU Pin out for CAMSHAFT sensor

Yes clip works, Renault ecu used..
Def 1.
What was the code, not the status code,,, (not P0 code, but renault code)

Is the van a runner,,,

Sometimes I wake up grumpy; other times I let her sleep

Currently in ours2012's garage:
My Baby ( or the shed on wheels )Laguna 2 estate with 8 months MOT..
ours2012 is offline  
post #3 of 41 (permalink) Old 4th September 2016 Thread Starter
Member
Threadstarter
 
Join Date: Sep 2016
Posts: 33
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 6
Thanked 3 Times in 2 Posts
re: Vivaro ECU Pin out for CAMSHAFT sensor

Once started it runs fine.

Will plug the Clip back in to get you code.

I got a picture of the definition it is "Speed Signal interference, tooth broken on the flywheel, engine speed sensor internal fault"
john86 is offline  
 
post #4 of 41 (permalink) Old 4th September 2016 Thread Starter
Member
Threadstarter
 
Join Date: Sep 2016
Posts: 33
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 6
Thanked 3 Times in 2 Posts
Angry re: Vivaro ECU Pin out for CAMSHAFT sensor

Put REN CLIP on

1 error present:
DF119 CAMSHAFT SENSOR SIGNAL 1.DEF
1.DEF= No camshaft signal or timming fault (tension or timming)

1 error stored but NOT Present
DF120 Engine Speed Sensor Signal 1.DEF
1.DEF= Speed Signal Interference, tooth broken on flywheel, engine speed sensor internal fault

I noticed that the crank sensor (engine speed sensor) was covered in oil , is this normal?

Put Multimeter on Camshaft cable (disconnected from engine) - got same readings with it plugged into both Camshaft sensors. Note engine was not started at this point of testing.
Brown wire got ground (Negative)
Blue and black stripe 11.8volts
Whitey cream and black stripe 12.8volts
Is this normal?

Would really appreciate your help guys
john86 is offline  
post #5 of 41 (permalink) Old 4th September 2016
Platinum member
 
A55ii's Avatar
 
Join Date: Dec 2012
Posts: 3,118
Nominated 12 Times in 7 Posts
Nominated TOTW/F/M Award(s): 3
Thanks: 39
Thanked 232 Times in 185 Posts
re: Vivaro ECU Pin out for CAMSHAFT sensor

where is our PIN expert when needed ?
Currently in A55ii's garage:
Megane Sports Tourer 106 1.5 dci , Clio 1.2 16v & A55 mk ii
A55ii is offline  
Reply

Tags
camshaft , ecu , pin , sensor , viavro , vivaro

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome