Renault Megane I - Speedo dead - Renault Forums :: Independent Renault forum

Electronics In Car Entertainment (ICE), Sat-Nav, lighting, wiring etc.

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 7th September 2008 Thread Starter
Junior Member
Join Date: Mar 2007
Posts: 11
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 1 Time in 1 Post
Renault Megane I - Speedo dead

Hi All, I have read through numerous posts on this forum about megane speedo problems and it looks like it is a very common problem. Anyway I have a 2000 1.4 megane and the speedo has stopped working completely, my car doesn't have a sensor on the gearbox and I believe it is run from an ABS sensor on one of the front wheel. I have changed the speedo clocks but still no luck, I dont have any fault lights on the dash, all lights go out as normal when the engine is started. The ABS system is working correctly, I have checked the earths on the engine block below the dipstick and also the ABS controller earths and all look good. What I am now looking for is a wiring diagram for the signal from the ABS unit to the clocks, is this direct or does it go through the ECU . If anyone could tell me the wiring pins/colours or if anyone has a wiring diagram or a link to one it would be much appreciated. Thanks.
Currently in Dwalsh's garage:
2001 Megane 1.9Dti
Dwalsh is offline  
  5 Lastest Threads by Dwalsh
Thread Forum Last Poster Replies Views Last Post
2003 Laguna 1.9 DCI Immobiliser Electronics mr espace 1 1481 16th March 2013 04:37 PM
Mk2 Phase 2 front on 2000 Clio Bodywork bedford561 1 919 12th June 2009 10:41 PM
Renault Megane I - Speedo dead Electronics cph1984 1 3502 7th September 2008 08:38 PM
Sponsored Links
post #2 of 2 (permalink) Old 7th September 2008
Diamond member
cph1984's Avatar
Join Date: Aug 2007
Posts: 803
Nominated 0 Times in 1 Post
Nominated TOTW/F/M Award(s): 1
Thanks: 3
Thanked 70 Times in 69 Posts
hi dwalsh. check out this thread as it may be of some help

Renault Megane 1 - No Speedo After Battery Change
Currently in cph1984's garage:
2001 VW Golf TDi
cph1984 is offline  

dead , megane , renault , speedo

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome