Laguna II Card/Card reader issue! - Renault Forums :: Independent Renault forum

Electronics In Car Entertainment (ICE), Sat-Nav, lighting, wiring etc.

LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 15th October 2008 Thread Starter
Junior Member
Join Date: Oct 2008
Posts: 2
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Laguna II Card/Card reader issue!


I have just purchased a Lagune II and the card intermittently works it could take 2 or 3 attempts for the card to work. But Today its stopped working all together it turns on to what would be on a normal car onto the ignition position 1 where the car lights up but it now wont start or release the steering lock. I have ordered another card reader today to see if that works as this seems to be the failure point. Would you say my diagnosis is correct i have spoke to a friend of mine at renault and he seems to think that is the issue.
benj1978 is offline  
  5 Lastest Threads by benj1978
Thread Forum Last Poster Replies Views Last Post
Laguna II Card/Card reader issue! Electronics deccam 6 4399 15th October 2008 03:41 PM
Sponsored Links
post #2 of 7 (permalink) Old 15th October 2008
Technical Supremo

Join Date: Feb 2007
Posts: 42,937
Nominated 16 Times in 67 Posts
Nominated TOTW/F/M Award(s): 28
Thanks: 372
Thanked 5,200 Times in 4,712 Posts
It could be a card reader fault - have you tried cleaning it with a vacuum cleaner - they are prone to collecting dust. On the other hand the internal micro-switches could be furbarred. They are not coded to the vehicle so a second hand unit may be an option

I have heard of people taking them out and giving them a blast with switch cleaner
Currently in madnoel10's garage:
Honda Civic 1.4l
madnoel10 is offline  
post #3 of 7 (permalink) Old 15th October 2008
Join Date: Jul 2007
Posts: 92
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 8
Thanked 1 Time in 1 Post
I had this on mine. The AA guy who came out suggested disconnecting the battery for 2 minutes, then reconnecting with the card in the reader. It worked!! As soon as he reattached the negative terminal the ignition switched on. This was about 4 months ago, it's happened again once since then. Obviously if you do this you need to reset the windows and re-enter the radio code.
I have read on here that disconnecting the battery on lagunas can cause problems (maybe someone else can advise?), so you have to consider that before you try it!!

Incidentally, how much was the reader?

Currently in craigieboy7's garage:
2002 renault Laguna II 1.8 Privilege
craigieboy7 is offline  
post #4 of 7 (permalink) Old 15th October 2008
Veteran Member
Technical Supremo
Lagdti's Avatar
Join Date: Dec 2005
Posts: 40,429
Nominated 2 Times in 20 Posts
Nominated TOTW/F/M Award(s): 18
Thanks: 149
Thanked 1,103 Times in 942 Posts
I think I'm right in saying that if the battery is disconnected and then everything is back working after it's reconnected,then it's more likely to be a UCH unit problem.I'd definately give it a go before spending out on a new reader Benj.

The Laguna 2 dash boards are very sensitive to having the batteries disconnected or jump starting,it's best to leave the side lights on whilst either is happening to help prevent voltage spikes from frying the circuit boards.

I'd rather push my Alfa than drive a BMW....
Currently in Lagdti's garage:
2004 Saab 9-5 HOT Aero and a 2001 Audi A3 1.8 Turbo
Lagdti is offline  
post #5 of 7 (permalink) Old 16th October 2008 Thread Starter
Junior Member
Join Date: Oct 2008
Posts: 2
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
I shall try this ASAP,

The reader i puchased was from a Running Laguna from Ebay and paid 49 for it

As per the other replys to the thread ill try this later on tonight I suppose it like and computer system they are all a little tempremental! Do they run on Windows lol!

If it is the card reader what is the process for changing it?

Is it just clipped in or do you need to remove parts of the dash? Also i would imagine its best to do this with the battey disconneted also?

Cheers for you reply everyone!
benj1978 is offline  

card or card , issue , laguna , reader

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome