Radio beeps and searches through stations - Renault Forums :: Independent Renault forum

Electronics In Car Entertainment (ICE), Sat-Nav, lighting, wiring etc.

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 28th October 2008 Thread Starter
Junior Member
Join Date: Oct 2008
Posts: 1
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Radio beeps and searches through stations

Hi all!

I have a huge problem that occures more and more often. The Renault I have is a Mégane II from 2000.

When I turn the radio on it starts searching through all stations, both on FM and AM. It stays on one channel for 2-3 seconds before it makes 2 loud beeps and then switches to the next station.
If I put a CD in the slot it starts searching through all the tracks! It starts from the last song, plating it for 2-3 seconds and the switches to the other. Beeping twice between the tracks here aswell.

These beeps get higher and higher each time (like the radio is turning the volyme up itself). This is completely random, if I switch the radio off I might get lucky and it works after an hour or so. One way to make it work though, is if I keep pressing (constantly) one of the buttons, believe it is the one at the bottom right end. But since my finger start to hurt after awhile this isn´t such a good solution...

I have searched the forums here but didnt find an answer to the problem. I also sent a email to Renault, they asked me to contact my local Renault dealer/garage (of course). But they seemed to be aware of the problem...

I would be very glad if anyone here know how to fix it? I´m in great need of the radio during work.

Thanks in advance // Ocke.

ps. Great idea with a Renault forum btw! ds.
Ocke is offline  
  5 Lastest Threads by Ocke
Thread Forum Last Poster Replies Views Last Post
Radio beeps and searches through stations Electronics madnoel10 1 664 28th October 2008 04:54 PM
Sponsored Links
post #2 of 2 (permalink) Old 28th October 2008
Technical Supremo

Join Date: Feb 2007
Posts: 42,935
Nominated 16 Times in 67 Posts
Nominated TOTW/F/M Award(s): 28
Thanks: 371
Thanked 5,199 Times in 4,711 Posts
Have you tried removing the radio fuse or disconnecting the battery to see if the radio goes back into default mode. About half-an hour max should be sufficient - don't forget you'll need the radio code when you reconnect. If that don't cure it I suspect a radio fault or a problem with its connections
Currently in madnoel10's garage:
Honda Civic 1.4l
madnoel10 is offline  

beeps , radio , searches , stations

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome