dashboard - Renault Forums :: Independent Renault forum

Electronics In Car Entertainment (ICE), Sat-Nav, lighting, wiring etc.

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 5th November 2008 Thread Starter
Junior Member
Join Date: Jul 2008
Posts: 19
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts

2002 laguna 1.9dci.. airbag symbol and SERV displaying.. am i correct in saying that the small connector relating to the seat belt/airbag under the passenger seat is the cause of this ?..Will disconnecting and reconnecting solve this ?..although gettin to it is a disaster !!
Currently in michman62's garage:
2006 meriva
michman62 is offline  
  5 Lastest Threads by michman62
Thread Forum Last Poster Replies Views Last Post
Megane refusing to start... Electronics michman62 3 912 11th March 2012 10:30 PM
No power. Engines andyellis111 4 957 6th April 2011 08:07 PM
Key is dead... Electronics michman62 4 967 28th January 2009 04:41 PM
dashboard Electronics dave_mezza2006 1 811 5th November 2008 09:34 PM
Sponsored Links
post #2 of 2 (permalink) Old 6th November 2008
dave_mezza2006's Avatar
Join Date: Jan 2007
Posts: 20,765
Nominated 6 Times in 11 Posts
Nominated TOTW/F/M Award(s): 5
Thanks: 1,498
Thanked 1,640 Times in 1,304 Posts
Hi Mich,

Yeah this will be the likely cause I imagine, it normally is. Might be prudent to get a diagnostics done one it though to be sure. Dont go to Renault for this though, I thinking Nationwide Auto Centres do diags at much cheaper rates.

Although when it happened to me if wasnt this as someone had already cut the connector off and soldered the wires (the proper fix for it) . The garage then removed both seat loom connectors under the seats and soldered all the wires up. and this still didnt resolve the problem

On my car it turned out to be a steering coloumn coupler that the wires pass through. Luckily this was replaced and fixed under warranty.

Hope you get yours sorted soon. First call is to try and access the connector, unplug it and plug it back in.
Currently in dave_mezza2006's garage:
2014 Vauxhall Astra Limited Edition 1.4 16v VVT Turbo
dave_mezza2006 is online now  


Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome