Megane oil pressure light? - Renault Forums :: Independent Renault forum

Electronics In Car Entertainment (ICE), Sat-Nav, lighting, wiring etc.

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 14th March 2006 Thread Starter
Join Date: Oct 2005
Posts: 31
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Megane oil pressure light?

The observant among you may recall my earlier postings on this problem, which is proving a real s** to pin down.

It's a 2000/W 1.6 Sport Alize. When accelerating from rest my oil pressure and stop lights flicker a few times then go out again. Eeek!

Having checked the pressure, given it a new pressure switch and then given the sump a clean and new oil and filter, someone gave me the blindingly obvious idea of pulling the wire off the pressure switch then driving it, to see what happened. And lo and behold the light STILL flickers, i.e. it's got nothing to do with the oil pressure at all! It MUST be something shorting in the wiring harness or similar.

Which is nice to know, but doesn't solve the problem. I've tried pushing and pulling at the harness to see if I can make the light flicker but no dice. The only feeble extra clue is that it flickers more easily when turning right than left, so it happens when accelerating forwards and/or to the right. Oh yes, and I guess the fact that it flickers rather than coming on steadily may mean it's close to the engine and responding to the vibrations therein.

Does anyone have any bright ideas for how to locate the problem? Or might a pragmatic approach be better, i.e. disconnect the stock wiring and adding my own bypass wiring for example? Thoughts please!
Currently in Greenmanalishi's garage:
2000 Megane Sport Alize 1600 Auto
Greenmanalishi is offline  
  5 Lastest Threads by Greenmanalishi
Thread Forum Last Poster Replies Views Last Post
Megane oil pressure light? Electronics bonedavid 1 2063 14th March 2006 08:05 AM
Renault Megane - Engines - Megane oil light Megane ghsaunders40 29 13087 12th February 2006 09:16 AM
Renault Megane - Wheels and Tyres - Best tyres? Megane mcouchard 19 16398 28th November 2005 02:17 PM
Renault Megane - Engines - Auto answers? Megane chris m 5 4652 2nd November 2005 01:14 PM
Renault Megane - Engines - Auto problems! Engines chris m 5 2728 1st November 2005 09:13 AM
Sponsored Links
post #2 of 2 (permalink) Old 16th March 2006
Platinum member
bonedavid's Avatar
Join Date: Jul 2005
Posts: 1,929
Nominated 0 Times in 1 Post
Nominated TOTW/F/M Award(s): 1
Thanks: 0
Thanked 11 Times in 4 Posts
Originally Posted by Greenmanalishi
Or might a pragmatic approach be better, i.e. disconnect the stock wiring and adding my own bypass wiring for example? Thoughts please!
sounds like it may be your best bet..taken one step at a time untill you identify the culprit.

rather you than me tho
Currently in bonedavid's garage:
women wild
bonedavid is offline  

light , megane , oil , pressure

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome