07 Megane totaly dead - Renault Forums :: Independent Renault forum

Electronics In Car Entertainment (ICE), Sat-Nav, lighting, wiring etc.

 5Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 35 (permalink) Old 1 Week Ago Thread Starter
Junior Member
 
Join Date: May 2017
Posts: 10
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
07 Megane totaly dead

Hi All.
I am new to the forum and hoping somebody can help with an electrical/electronic problem I have. I have read through similar experiences but cant find anything total like my issue.
I started off when I was unable to open the door using the key card so I used the manual key instead. I got in the car and started as normal. I tried to use the indicators but they were not working. On the dashboard display were various warning messages such as brake failure, steering unlocked. I stopped the engine and called roadside assistance. While waiting for the recovery vehicle, I started the engine again, The same warning messages were there so I tried to stop the engine bit it wouldn't so I had to stall it in gear. Now all the lights came on ( I couldnt turn them off), indicator lights on but not flashing and electric windows not working.
When the recovery vehicle arrived, he started the car but he also had to stall it to stop it. He plugged in the computer diagnostics which came up with a fault with the glow plug module control circuit. The car was taken back to my home and nothing at all was working, I assumed because the battery was now flat.
5 minutes after the recovery vehicle left, all the lights suddenly came on again without me touching the vehicle. I had to disconnect the battery (earth first) to turn everything off.
The next day, while i was in work, a friend had a quick look for me. He suspected a faulty battery so went out and bought a new one but it was still totaly dead. He also bought a new battery for the keycard.
I have read all the similar faults with the warning messages and damp in the ecu /fuse box. I have checked the fuses on the battery and there is good continuity across theses terminals. Full battery power is going to the big bolt terminal at the engine bay fuse box and also to the ECU and everything is looking clean with no sign of any water corrosion to the terminals. However, absolutely nothing is working electrically.
Sorry about the long winded first post but I know with fault finding its important to get all the facts.
Does anybody have any suggestions of what it could be. Would an ECU failure show up as this intermittent fault followed by the vehicle being totally.
vinndy
vinndy is offline  
  5 Lastest Threads by vinndy
Thread Forum Last Poster Replies Views Last Post
07 Megane totaly dead Electronics rik220 34 594 19th May 2017 05:15 AM
Sponsored Links
Advertisement
 
post #2 of 35 (permalink) Old 1 Week Ago
Member
 
jimmymarsbar's Avatar
 
Join Date: Jul 2016
Posts: 64
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 3
Thanked 1 Time in 1 Post
Garage
Re: 07 Megane totaly dead

Check the earth straps. It might be worth checking the BSI for any loose connectors and fuses.
Currently in jimmymarsbar's garage:
Megane 1.5dCi Estate, 307 2.0 Hdi, Fiesta 1.4 Zetec
jimmymarsbar is offline  
post #3 of 35 (permalink) Old 1 Week Ago
Veteran Member
Technical Supremo
 
Dancingdad's Avatar
 
Join Date: Dec 2013
Posts: 11,572
Nominated 43 Times in 38 Posts
Nominated TOTW/F/M Award(s): 15
Thanks: 1,006
Thanked 2,089 Times in 1,646 Posts
Re: 07 Megane totaly dead

And for damp inside car..... floor, underfloor cubby holes and up behind dash.
Currently in Dancingdad's garage:
Qashqai 1.6 spark driven, Kia Sedona 2.9 TDI, Scenic II 15DCi 2004 (SORN) not quite RIP.
Dancingdad is online now  
 
post #4 of 35 (permalink) Old 1 Week Ago Thread Starter
Junior Member
Threadstarter
 
Join Date: May 2017
Posts: 10
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 07 Megane totaly dead

Thanks for the replies. I get full battery voltage between the battery +ve terminal and the engine and bodywork earth. Where Would I find the BSI. Is this the body control module? What function does it have?
I have checked inside the car and its bone dry and all the fuses are intact.
If there was a fault with the ECU , would I not be able to switch on anything- interior lights, hazard lights, radio.
I dont get any reaction at all on the central locking when using the key card either.
vinndy is offline  
post #5 of 35 (permalink) Old 1 Week Ago
Honorary Yorkshireman just in Derbyshire
 
Nottnoc's Avatar
 
Join Date: Dec 2008
Posts: 9,500
Nominated 33 Times in 22 Posts
Nominated TOTW/F/M Award(s): 8
Thanks: 1,745
Thanked 1,971 Times in 1,535 Posts
Re: 07 Megane totaly dead

ECU Stands for ENGINE control Unit. So NOT that.
BCM (UCI French name) Is the BODY control module.
WTF is a BSI?
Have you checked the Fuses on the Battery +Ve Connection?

Regards Tim,
You are only young once, but you can be immature forever
Give a n00b the answer he will be learn for a day; show him the search button, he will learn for life.
Currently in Nottnoc's garage:
2008 Scenic Mk2 Dynamique 1.6 K4M 812. 1998 BMW K1100LTSE, 1994 MotoGuzzi Caifornia 3 LAPD, 1972 Norton Commando, 2010 Trafic SL29 M9R786 115, Lots of tools, Camping Gear & Booze
Nottnoc is offline  
Reply

Tags
dead , megane , totaly

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome