speedo stops now and then - Renault Forums :: Independent Renault forum

Electronics In Car Entertainment (ICE), Sat-Nav, lighting, wiring etc.

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 25th November 2008 Thread Starter
Diamond member
Join Date: Jul 2008
Posts: 481
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 4 Times in 4 Posts
speedo stops now and then

hi, my 1999 ph 1 scenic 2 litre 8 valve automatic. has begun playing up in the speedo, sometimes it stops and after a few mins or go over a few bumps and it starts again,makes me think its a loose wire somewhere as its electronic not cable fed, or could it be a sensor?. hate to get caught speeding, any advice most appreciated
Currently in petercee's garage:
1998 scenic rxe
petercee is offline  
  5 Lastest Threads by petercee
Thread Forum Last Poster Replies Views Last Post
help required with car stereo Electronics madnoel10 7 1703 9th August 2010 04:43 AM
dead scenic Engines petercee 4 1243 19th December 2009 04:59 AM
Scenic rear speakers Electronics petercee 2 1513 28th November 2009 10:21 PM
Sponsored Links
post #2 of 3 (permalink) Old 26th November 2008
Let's be carefull out there
chris m's Avatar
Join Date: Jan 2006
Posts: 19,344
Nominated 1 Time in 1 Post
Nominated TOTW/F/M Award(s): 3
Thanks: 3
Thanked 32 Times in 32 Posts
Send a message via MSN to chris m
I think it will have an electrical connection as opposed to a manual cable. Make sure the connector at the gearbox end is clean and firm
Currently in chris m's garage:
2000 Scenic 2.0 16v Monaco, BMW 3 Series, Pug 206
chris m is offline  
post #3 of 3 (permalink) Old 23rd December 2008
Junior Member
Join Date: Oct 2008
Posts: 4
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Intermittent speedo?

Hi there,
I have a 1.4 scenic 16v w reg.
After a sudden braking incident earlier today I noticed that my speedo needle started to jump about , then settle for a short while then start again .
Also when the ignition is switched off the oil light & handbrake light are on very dim until the immobiliser led starts to flash,
any ideas , could it be a broken wire or crappy connection?

Any help is much apprecited
Currently in johnny2bob's garage:
2000 1.4 16v scenic
johnny2bob is offline  

speedo , stops

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome