Clio Campus Stereo/Display problem! - Page 2 - Renault Forums :: Independent Renault forum

Electronics In Car Entertainment (ICE), Sat-Nav, lighting, wiring etc.

LinkBack Thread Tools Display Modes
post #6 of 7 (permalink) Old 6th January 2009
Technical Supremo

Join Date: Feb 2007
Posts: 42,935
Nominated 16 Times in 67 Posts
Nominated TOTW/F/M Award(s): 28
Thanks: 372
Thanked 5,199 Times in 4,711 Posts
No matter how long I stare at the picture of the patch lead I can't see three connectors.

Have a look through the site below - it may be of assistance
Currently in madnoel10's garage:
Honda Civic 1.4l
madnoel10 is offline  
Sponsored Links
post #7 of 7 (permalink) Old 7th January 2009 Thread Starter
Junior Member
Dave_minall's Avatar
Join Date: Jan 2009
Posts: 4
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
I don't want to know if my patch lead has three connectors! I just need to know if I have to take my dashboard off to get to the back of the display?

Surely someone on on here will know?


Currently in Dave_minall's garage:
Renault Clio Campus 2008
Dave_minall is offline  

campus , clio , problem , stereo or display

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome