Laguna II phase 1 trip computer not working - Page 2 - Renault Forums :: Independent Renault forum

Electronics In Car Entertainment (ICE), Sat-Nav, lighting, wiring etc.

LinkBack Thread Tools Display Modes
post #6 of 8 (permalink) Old 18th February 2009 Thread Starter
Junior Member
Join Date: Feb 2009
Posts: 9
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Resolved - trip computer and dash is fine. I wasn't pushing the stalk button in firmly enough it seems....pressed a little harder and was able to scroll through the functions no problem!

So the only issue is replacing the stalk, as the button contact seems to be rather tired....
Currently in almostwelsh's garage:
'01 Laguna II 1.8 Authentique, '03 Fiesta 1.4 TDCi, 2 x Honda NTV650's.
almostwelsh is offline  
Sponsored Links
post #7 of 8 (permalink) Old 18th February 2009
Diamond member
owenfackrell's Avatar
Join Date: Dec 2007
Posts: 447
Nominated 1 Time in 1 Post
Nominated TOTW/F/M Award(s): 1
Thanks: 3
Thanked 5 Times in 5 Posts
The stalk is easy enough to replace but you do have to take the cowling apart which i can't remember if you need to take the wheel off for. i would look on ebay for a scraped car for the part.
Currently in owenfackrell's garage:
2006 laguna II, initiale sports tourer 2.0Dci , but has had laguna 1 rxe (both phases) and a 98 clio rxe and a Laguna II Sports Tourer 1.9Dci Privilege and a Megane Coupe 2.0 16v in red and a 2007 57 plate megane II privilege 1.5 DCi estate (with Panoramic sunroof) and a 2001 Clio 1.4 Privilagein black.
owenfackrell is offline  
post #8 of 8 (permalink) Old 18th February 2009
Diamond member
Join Date: Mar 2007
Posts: 205
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 6 Times in 6 Posts
You could try a squirt of liquid engineering (wd40) into the end of the stalk before you look for the expensive option, the button works, so it may just be stiff with lack of use, just a thought!
Currently in Daddio's garage:
2005 Grand Scenic 1.5 dci
Daddio is offline  

laguna , phase , trip , working

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome