How To :- Replace the Factory Fitted Head Unit in a Megane I (with Pictures) - Renault Forums :: Independent Renault forum

Electronics In Car Entertainment (ICE), Sat-Nav, lighting, wiring etc.

LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 21st February 2009 Thread Starter
kip's Avatar
Join Date: Feb 2009
Posts: 79
Nominated 0 Times in 0 Posts
Nominated TOTW/F/M Award(s): 1
Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs up How To :- Replace the Factory Fitted Head Unit in a Megane I (with Pictures)

I've just posted this on my blog - but thought it might be handy for some of you.

If you've still got a factory fitted head unit - you might want to consider upgrading to a new head unit. This does mean the external display will no longer show the radio station you're tuned to - or the track number of the CD (although some Sony Head Units allow this!) - BUT - you will notice a big difference in how it sounds! Thankfully you can purchase a wiring loom that will allow you to use the stereo controls on the steering column.

The Megane I space where the existing radio sits isn't standard and you need to get a 'fascia' apdater to allow a standard head unit to fit. These can be purchased all over the place - I got mine on eBay - and it came with the tools to remove the existing stereo too!

The next thing you need a wiring loom to connect the existing wiring to the new stereo, and also an adapter that is specific to your brand of stereo (in my case Kenwood) to allow the controls to be used. As my head unit is a little older - it has a single blue and yellow wire that connects to the adapter.

Also required for the job is a T20 (Torx) screwdriver and a flat headed screwdriver incase the tweeter grills are a bit stiff to pop off!

Okay - this isn't as daunting as it looks - it will take you about 30 mins or so.

First job is to get the old stereo out - dead simple - just poke the removal tool into the holes and it should just pull out. You should be left with something like this :-

You'll notice the plastic frame is left - this needs to be removed - it unclips easily.

Right - now it's time to put the fascia in, it's just a case of pushing it in. It has little clips that will 'click' when they are where they should be. It does take a little welly to get it 'home'. Test it is secure by trying to pull it back out (obviously you don't want the new stereo flying out!! Once it's in you'll have this :-

Right - that's as much as we need to do down there right now. The next job is taking the top of the dash off - it's only held in with two T20 screws which are hidden under the two tweeter covers. So pop these off - you probably can get them off by hand - or with a flat bladed screw driver :-

You can see the screw here on the left of the photo :-

Next do the same on the other side :-

Okay - now it's time to pull the top of the dash off - you need to pull it towards you and upwards - you'll have to drop the steering column right down to get it out. Once it's off stick it on the back seats and you'll have something like this :-

Next you need to remove the three T20 screws that hold the display in place - then gently pull out the display.

You need to unclip the red connector from the socket on the display. You then need to feed the red socket on your Autoleads wiring loom up through where the stereo will go up the right hand side of the centre console. Plus the connector and socket together. As shown below :-

Make sure the connector is pressed firmly in. NOTE - neither of the red connectors should be plugged into the display now. Okay tidy the wires and screw the display back into position. Leave the dash top off for now just in case.

Now is a good time to fit the Stereo 'cage' into the fascia- you'll have to bend out some of the metal pins so it stays tightly in the fascia. Feed the wires through the cage and start wiring it up.

You will have a black (5?) pin connector left over - you don't need this. Don't forget to wire the remote control lead :-

Now is a good time to test it actually works - so turn the key and see what happens hopefully this! :-

If nothing happens - go back and check all your connections and fuses. One thing to test is try 'saving' a radio station, and then turn the ignition off. If you switch it back on the station should still be stored. If it isn't then you need to switch around the red and yellow wires on the power connector (pins 4 and 7 I think). All you need is a very small screw driver to loosen the pins and switch them over. I had to do this on mine!

Next job is to put the stereo in place. you need to ensure no wiring is trapped or strained. Just push it gently in, if it doesn't go fully in, then take it out, and re-arrange the wires and try again. There's no science to it - just lots of trial and error. Once it is in you should have this :-

Now put the dash top back (it's probably a good idea to give it a clean before you put it back!). Then you're done and will have a nice shiny new stereo!

Hope this helps someone!

Last edited by kip; 21st February 2009 at 04:09 PM. Reason: Trying to fix the images!
kip is offline  
  5 Lastest Threads by kip
Thread Forum Last Poster Replies Views Last Post
Megane I Knocking Noise (Clutch?!?) * FIXED * Engines dave_mezza2006 12 2974 25th August 2009 03:22 PM
Megane I - Matrix Removal Heating & cooling kip 5 1771 23rd August 2009 02:23 PM
Megane I - Starting Problem Engines kip 4 1104 9th June 2009 10:16 AM
What Alloys for my Megane I ? Wheels & tyres lockster0191 1 1095 27th February 2009 06:35 PM
Megane I 1.4 RT - Idling Low / Warning Lights Engines kip 6 1764 25th February 2009 09:43 AM
Sponsored Links
post #2 of 12 (permalink) Old 21st February 2009
Let's be carefull out there
chris m's Avatar
Join Date: Jan 2006
Posts: 19,344
Nominated 1 Time in 1 Post
Nominated TOTW/F/M Award(s): 3
Thanks: 3
Thanked 32 Times in 32 Posts
Send a message via MSN to chris m
Good post, well done
Currently in chris m's garage:
2000 Scenic 2.0 16v Monaco, BMW 3 Series, Pug 206
chris m is offline  
post #3 of 12 (permalink) Old 21st February 2009 Thread Starter
kip's Avatar
Join Date: Feb 2009
Posts: 79
Nominated 0 Times in 0 Posts
Nominated TOTW/F/M Award(s): 1
Thanks: 0
Thanked 0 Times in 0 Posts
Thanks! I love pictures with how to guides so thought i'd take them and hopefully help someone else!

kip is offline  
post #4 of 12 (permalink) Old 21st February 2009
Platinum member
bpowell555's Avatar
Join Date: Apr 2007
Posts: 2,861
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 2
Thanked 20 Times in 18 Posts
Love the way u can take the top of the dash off - well handy

Currently in bpowell555's garage:
2002 Renault Laguna II 2.2dCi Initiale, 1990 E30 325i Touring (Bavarian Tigzwerken Express)
bpowell555 is offline  
post #5 of 12 (permalink) Old 21st February 2009
Platinum member
pragmatix's Avatar
Join Date: Sep 2007
Posts: 5,543
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 21
Thanked 48 Times in 46 Posts
Nice post, well done

The older I get the better I was, must be mad not got enough money to be excentric
Currently in pragmatix's garage:
Ford Mondeo Ghia X estate, Skoda Roomster 1.6 Alfa Mito1.4 veloce,Cervelo S2, Gaint Defy Advanced e
pragmatix is offline  

factory , fitted , head , head unit , how to , megane , pictures , replace , replacing , unit

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome