Saga continues with the ecu!!!!! - Renault Forums :: Independent Renault forum

Electronics In Car Entertainment (ICE), Sat-Nav, lighting, wiring etc.

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 22nd February 2009 Thread Starter
Junior Member
Join Date: Feb 2009
Posts: 7
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Saga continues with the ecu!!!!!

Hi all,
After purchasing my Laguna II, ive had nothing but problems. Everything is sorted now apart from the electrics!
When you first turn the car on it just hunts at 2k rpm and allows no throttle at all, then when you restart it its ok but wont go above 3k rpm (i think its called limp mode).
I have taken it to the garage and they cannot locate the fault. The keep resetting the faults but then they come back different everytime.

Now i think the problem is with the ecu . I am going to get it back and check the connections for corrosion first but i fear i may need a new ecu . Does this require decoding/reprogramming for my key etc

Any help will be much appreciated.

Many thanks in advance

monkey47 is offline  
  5 Lastest Threads by monkey47
Thread Forum Last Poster Replies Views Last Post
New ECU Electronics mwlaguna2 1 1036 7th March 2009 06:44 PM
Saga continues with the ecu!!!!! Electronics Jules 1 884 22nd February 2009 06:43 PM
Clutch master and slave cylinder Engines Lagdti 1 1248 10th February 2009 04:53 PM
Renault Laguna 1.6 expression not revving past... Electronics Mikey 5 2047 5th February 2009 09:24 AM
Sponsored Links
post #2 of 2 (permalink) Old 23rd February 2009
Diamond member
Jules's Avatar
Join Date: Sep 2005
Posts: 270
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 6 Times in 4 Posts
Follow the advice given in this thread to locate and clean the 'throttle position sensor'

Scenic surging then hesitant, lack of power

Currently in Jules's garage:
2005 Laguna Initiale 2.2 DCI Hatchback
Jules is offline  

continues , ecu , saga

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome