1.9 dci fidgi 2002 - Renault Forums :: Independent Renault forum

Electronics In Car Entertainment (ICE), Sat-Nav, lighting, wiring etc.

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 24th February 2009 Thread Starter
Junior Member
Join Date: Feb 2009
Posts: 4
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
1.9 dci fidgi 2002

does anybody have any ideas on why the pre heater plug light comes on after 5 min then eventually goes off. This isnt related to speed or temp as it happens when only now and again. Im only asking as as it only happens once a week if that and i know if i take it to a garage they will say bring it in when lights on aaaaaaarrrrrgh any clues. Would appreciate
colg is offline  
  5 Lastest Threads by colg
Thread Forum Last Poster Replies Views Last Post
1.9 dci fidgi 2002 Electronics colg 2 692 24th February 2009 07:57 PM
Sponsored Links
post #2 of 3 (permalink) Old 25th February 2009
Diamond member
levski's Avatar
Join Date: Dec 2008
Posts: 149
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 2
Thanked 3 Times in 3 Posts
Welcome to the club!

This goes back several months and several posts - I also have a Megane 1.9dCi Fidji (2001 model) which started to display similar symptoms to the one you mentioned.

The problem is the glow plug (pre-heater) warning light can come on for a number of reasons.

For example, it will come on when you start the car to inform you that the glow plugs have been activated. According to the Haynes manual, glow plug heating has several phases - pre-heating, starting heating and post heating. Haynes states that "the maximum period of variable post heating is 3 minutes"

Without extracting the whole section from the Haynes manual (and I'd probably get told off for by the moderators for doing so due to copyright reasons!) - it COULD be that the system has detected a problem with the glow plugs, glow plug relay etc etc.

I'll leave at that for now but just to ask, you said "the pre heater plug light comes on after 5 min then eventually goes off"

Are you sure its 5 minutes?
How long does the light stay on for?
Does the car's performance suffer when the light is on?
Have you had any problems starting the car?
How old are the glow plugs?

....anything else you can think of

Give me some more information and I'll share what I can with you.

Currently in levski's garage:
2001 Renault Megane 1.9dCi
levski is offline  
post #3 of 3 (permalink) Old 26th February 2009 Thread Starter
Junior Member
Join Date: Feb 2009
Posts: 4
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
responce to glow plug light

it starts fine as it did when we had 18k on it no smoke from exhaust no difference in performance hesitation and you can switch the engine off for about 2 mins and it will go off ( not leaving it to cool down ). Rarely after light comes on and you have stopped the idle revsa are a little erratic even if light goes off, but again if you switch it off and back on again everythings normal. The only thing i have done out of the ordinary is put a new battery on a month ago??????
colg is offline  

dci , fidgi

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome