Megane 11x84sp - wiper relay - Renault Forums :: Independent Renault forum

Electronics In Car Entertainment (ICE), Sat-Nav, lighting, wiring etc.

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 11th April 2009 Thread Starter
Junior Member
Join Date: Apr 2009
Posts: 1
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy Megane 11x84sp - wiper relay


Bought a 2004 Megan Sports this week. The car was purchased at auction so a complete check of the electrics was not possible before purchase. The wipers were not required but the wiper switch had been left on. A burning smell was noticed on the drive home. The smell appeared to be cycling on and off over 3 to 5 minutes. Closing the vent and recirculating cabin air did not reduce the smell. When selecting wipers for the first time I discovered they did not work. The wiper switch was turned off and the burning smell didn't re-appear. When checking wiper motor it appears as if the linkages may have ceased at some stage due to water being trapped in area due to blocked drains.There was water trapped in the area under the front windscreen. The power wire for the motor was imersed in water and the shrink wrap where it passed through the left drain had split. There was however no exposer of bare wires to water.The linkages were luricated and the wiper motor tested Ok on work bench. There is no power being supplied to motor. The problem appears to be under the dash. How do I locate the wiper relay, How do I remove the glove box and what else could be the problem. Any ideas much appreciated.
Currently in lisaar's garage:
2004 Megane X84 11 sport 2l turbo
lisaar is offline  
  5 Lastest Threads by lisaar
Thread Forum Last Poster Replies Views Last Post
Megane 11x84sp - wiper relay Electronics Lagdti 1 1444 11th April 2009 09:53 AM
Sponsored Links
post #2 of 2 (permalink) Old 11th April 2009
Veteran Member
Technical Supremo
Lagdti's Avatar
Join Date: Dec 2005
Posts: 40,429
Nominated 2 Times in 20 Posts
Nominated TOTW/F/M Award(s): 18
Thanks: 149
Thanked 1,103 Times in 942 Posts
Hello and welcome to the forum.

As far as I know there won't be a wiper relay on your car,they will be controlled by the UCH unit.It is possible that it has blown a fuse,and that they smell you are getting is from a heater fan rheostat.

The UCH unit is a temperamental piece of kit,if you dry all the connections to the wipermotor and disconnect the UCH for a few hours you might find that all is well again.

I'd rather push my Alfa than drive a BMW....
Currently in Lagdti's garage:
2004 Saab 9-5 HOT Aero and a 2001 Audi A3 1.8 Turbo
Lagdti is offline  

11x84sp , megane , relay , wiper

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome