Clio problems - Renault Forums :: Independent Renault forum

Electronics In Car Entertainment (ICE), Sat-Nav, lighting, wiring etc.

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 14th April 2009 Thread Starter
Junior Member
Join Date: Apr 2009
Posts: 1
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Clio problems

Hi people,

I am brand new to this forum (I'm from Australia), as I have recently purchased a 2003 Clio 2.0 Sport. For the most part I'm loving the car. But just got a problem that the previous owner has no knowledge (reportedly) of. I started it a couple of days ago and the revs were all over the place. At first it was just over-revving. Like a car would if it was cold and the auto-choke was keeping the enging going to get it warm. But even when the engine was up to temp. it still kept the RPM at around 2000-2500!!! Then it would drop and go up independant of my foot on the accelerator!?!?! Eventually the warning light came up on the dash saying there was an electronic problem and to contact a dealer.
Well I have had it towed to an auto electrician and he is suggesting a new Throttle Body . I'm not too keen as I think (from reading other forums) that this is too expensive, and will not solve the problem. The electrician said this morning that the car was now behaving fine....
I have read about this black box at the back of the engine. Could this be the problem? I need help!!!!

TomLucia is offline  
  5 Lastest Threads by TomLucia
Thread Forum Last Poster Replies Views Last Post
Clio problems Electronics madnoel10 1 611 14th April 2009 06:01 AM
Sponsored Links
post #2 of 2 (permalink) Old 14th April 2009
Technical Supremo

Join Date: Feb 2007
Posts: 42,935
Nominated 16 Times in 67 Posts
Nominated TOTW/F/M Award(s): 28
Thanks: 371
Thanked 5,199 Times in 4,711 Posts
A duf or dirty throttle body wil cause the revs to be inconsistent. In many cases a proper clean up will cure the problem - so that would be my first option. Also check there are no leaks around the inlet plumbing or manifold
Currently in madnoel10's garage:
Honda Civic 1.4l
madnoel10 is offline  

clio , problems

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome