Clio Instrument failure - Renault Forums :: Independent Renault forum

Electronics In Car Entertainment (ICE), Sat-Nav, lighting, wiring etc.

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 29th May 2009 Thread Starter
Junior Member
Join Date: May 2009
Posts: 2
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Clio Instrument failure

Hi All

I'm posting on behalf of the wifes Grandfather
His Clio 1.2 on a 51 plate has had problems with the instruments on the dash panel packing up!
His local garage can sort it by wiggeling the plug from the loom to the dash but it fails again after a few days (& only a few miles) usually on the next shopping trip
Its been to the local dealer who quoted 500 to replace the dash panel! WTF!!!!!
To me it sounds like a dry joint or a cracked track on the pcb?
Is this common?
Has anyone else had the sameor similar problems?
Currently in SANDMAN's garage:
Clio 1.2, Pug 406 HDI est, Discovery 300Tdi, Beetle 1300
SANDMAN is offline  
  5 Lastest Threads by SANDMAN
Thread Forum Last Poster Replies Views Last Post
Clio Instrument failure Electronics planmeca 1 1010 29th May 2009 09:32 PM
Aye Up Welcome to RenaultForums dave_mezza2006 5 949 29th May 2009 09:09 PM
Sponsored Links
post #2 of 2 (permalink) Old 29th May 2009
Platinum member
planmeca's Avatar
Join Date: Feb 2007
Posts: 2,448
Nominated 0 Times in 3 Posts
Nominated TOTW/F/M Award(s): 1
Thanks: 332
Thanked 323 Times in 277 Posts
I think you're on the right track there (excuse the pun) Its really a case of getting hold of the loom and the dash and moving it slowly till you find the point it fails.

As you have mentioned the pcb I guess you are a hands on guy who may be able to bridge the track (if it is a track that has broken) thats at fault.

If you have a test meter check out each individual wire from the plug to the pcb in turn till you find the break.

Its possible that the plug or socket is at fault, again use the meter on resitance range to check it out

It may also be simply a case of using a suitable switch cleaner on the contacts (maplins do one)
Currently in planmeca's garage:
Renault Laguna 1.8 16v x 2 and a lot of other things. could really do with a tidy up to be honest I'll do it tomorrow
planmeca is offline  

clio , failure , instrument

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome