Twingo - Loads of warning lights on after sitting for a few months - Renault Forums :: Independent Renault forum

Electronics In Car Entertainment (ICE), Sat-Nav, lighting, wiring etc.

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 8th June 2009 Thread Starter
Join Date: Feb 2006
Posts: 39
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 2
Thanked 1 Time in 1 Post
Twingo - Loads of warning lights on after sitting for a few months


My wife and I bought an ex demo Twingo (2007 model) in Sept 08. We have been looking to sell it and it's been sitting in our drive for a few months and hasnt been started during that time. Tonight I went and took it out., but found dreaded problems!!

On starting the car the Handbrake light, STOP light, ABS light and service (spanner) light are all on. When it's driven the steering feels slightly heavy. Also the digital MPH readout is blank - just 2 dashes - -.

I'm thinking it's because its been lying in the drive, possibly a weak battery?

Any info would be great, I'm gona have to bring it to a dealer to look at but would like to know any toughts.

Currently in Frazer's garage:
2005 Mégane II 1.5dCi Dynamiqué
Frazer is offline  
  5 Lastest Threads by Frazer
Thread Forum Last Poster Replies Views Last Post
Few queries: mirror/door handles/seat adjuster Interiors Frazer 1 425 15th April 2015 09:26 PM
Megane standard and 225 springs Steering and Suspension Frazer 5 721 14th April 2015 03:03 PM
Doing a service yourself Engines Frazer 7 931 23rd February 2015 02:25 PM
Hello all Welcome to RenaultForums Frazer 4 547 20th February 2015 08:10 AM
Clio II - Lack Of Blower Heat Heating & cooling Frazer 2 840 25th June 2012 09:39 PM
Sponsored Links
post #2 of 3 (permalink) Old 8th June 2009
dave_mezza2006's Avatar
Join Date: Jan 2007
Posts: 20,768
Nominated 6 Times in 11 Posts
Nominated TOTW/F/M Award(s): 5
Thanks: 1,498
Thanked 1,647 Times in 1,306 Posts

It could well be the battery you know.
Currently in dave_mezza2006's garage:
2014 Vauxhall Astra Limited Edition 1.4 16v VVT Turbo
dave_mezza2006 is online now  
post #3 of 3 (permalink) Old 8th June 2009
Technical Supremo

Join Date: Feb 2007
Posts: 42,940
Nominated 16 Times in 67 Posts
Nominated TOTW/F/M Award(s): 28
Thanks: 372
Thanked 5,201 Times in 4,712 Posts
It could be a duff battery problem and renaults just don't like poor voltage - dash starts to do crazy things, etc.. It may be worth charging the battery and getting it load tested - many decent battery suppliers wil do a free test in the hope of a sale
P.S. Get the alternator output checked at the same time.
Currently in madnoel10's garage:
Honda Civic 1.4l
madnoel10 is offline  

lights , loads , months , sitting , twingo , warning

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome