Renault Megane Problems - Renault Forums :: Independent Renault forum

Electronics In Car Entertainment (ICE), Sat-Nav, lighting, wiring etc.

LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 1st July 2009 Thread Starter
Junior Member
Join Date: Jul 2009
Posts: 1
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Renault Megane Problems

Hello im on here seeking for help on my Renault Megane Dynamique DCI 80 1.5 2003.

Today i got into my car and turned the engine on. I turn the radio off .. and the clock is supposed to stay on when the radio is off but it doesnt appear whilst the radio is off.

So thats problem number one

My air conditioning does not work at all, the light does not even come on to tell me weather its on or off.

Problem number 2

The back demister light does come on.

Problem number 3

The last problem is When i lock or unlock the car there is a continuous tone that stays on for a couple of seconds.

Any help is apprieciated


RockyOc is offline  
  5 Lastest Threads by RockyOc
Thread Forum Last Poster Replies Views Last Post
Renault Megane Problems Electronics jamilkai 5 1548 1st July 2009 02:30 PM
Sponsored Links
post #2 of 6 (permalink) Old 1st July 2009
Junior Member
Join Date: May 2009
Posts: 7
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs up

There is a 15amp fuse which controls the functions you are describing. On my 06 plate it is located in the glovebox fusebox, not too sure if yours will be in the same place though.
Currently in diegodargo's garage:
2006 Megane Sport Tourer 1.9dci 130 FAP
diegodargo is offline  
post #3 of 6 (permalink) Old 1st July 2009
Junior Member
Join Date: Apr 2009
Posts: 3
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts

hi guys i also have some problems with my megane coupe 1998, if somebody could help me:

1 - my speedmeter(km/h or mile/h) is not working well(it markes a variable speed even when the car is parked,sometimes i feel that the speedmeter follows the RPM),i've changed the speed sensor many times but the problem is always the same..

2 - the front left windows is not working,the glass is in the door & when i try to pull it up i hear a voice of something getting broken "krikrik" ..

3 - the third one is not a problem but its a stupid thing that i did ---> yesterday i've painted the cover of the exhaust near the engine( the metal one ) with a normal spray not a specific one for hight temperature --> concequence : i smell the odeur of plastique burning in the engine..what could i do to stop thing ..

THX in advance ..
jamilkai is offline  
Old 1st July 2009
This message has been deleted by dave_mezza2006. Reason: not helpuful to the thread
post #4 of 6 (permalink) Old 1st July 2009
Veteran Member
Technical Supremo
Lagdti's Avatar
Join Date: Dec 2005
Posts: 40,429
Nominated 2 Times in 20 Posts
Nominated TOTW/F/M Award(s): 18
Thanks: 149
Thanked 1,103 Times in 942 Posts
It is true,the experts you find on here really are the finest on t'internet.

I'd rather push my Alfa than drive a BMW....
Currently in Lagdti's garage:
2004 Saab 9-5 HOT Aero and a 2001 Audi A3 1.8 Turbo
Lagdti is offline  
Old 2nd July 2009
This message has been deleted by Devils Laguna.
post #5 of 6 (permalink) Old 2nd July 2009
Technical Supremo

Join Date: Feb 2007
Posts: 42,940
Nominated 16 Times in 67 Posts
Nominated TOTW/F/M Award(s): 28
Thanks: 372
Thanked 5,200 Times in 4,712 Posts
Here's a few humourous definitions of an expert

A person who knows enough about what's really going on to be scared.

An expert is someone who knows one thing more than you on any given subject. But it doesn***8217;t mean that one thing is right or even real.

But back to the post by Jamilkai!!

1. The speedo problem may be the result of a fault in the speedo sensor wiring whereby the sensor has a poor earth - quite a common problem - so it may be worth investigating that aspect.

2. The noise coming form the window could well be damaged cables or or guides in the window regulator mechanism. The door liner would need to be removed for further investigation.

3. The paint odour problem may be solved by cleaning the area with thinners (make sure the engine is cold first) and allowing it to dry off for an hour or so. Start the engine until the area is slightly warm - switch off the engine and let it sit overnight with the bonnet open. Any remaining smells should disapate over a few days at most.

Good Luck Jamilkai
Currently in madnoel10's garage:
Honda Civic 1.4l
madnoel10 is offline  

megane , problems , renault

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome