Need help with Clio MK1 1.2 Oasis - Page 2 - Renault Forums :: Independent Renault forum

Electronics In Car Entertainment (ICE), Sat-Nav, lighting, wiring etc.

LinkBack Thread Tools Display Modes
post #6 of 11 (permalink) Old 25th April 2006
Veteran Member
Technical Supremo
Lagdti's Avatar
Join Date: Dec 2005
Posts: 40,429
Nominated 2 Times in 20 Posts
Nominated TOTW/F/M Award(s): 18
Thanks: 149
Thanked 1,103 Times in 942 Posts
For the cooling system bleed,follow Oilyrags procedure in the previous posts.He knows what he's doing(well sort of!).I know him,we share the same mum and dad!

As for your fault,I would seriously get the oil pressure checked at a garage with a proper test gauge,just to rule out any expensive problems!.If oil pressure is suspect,then it will show itself when the engine is warm( oil thinner) and on tick over(pump running slowly).

If the pressure checks out OK,then suspect the pressure switch(electrical switch that is activated by oil pressure and when no pressure is detected it puts the dash light on).

It's strange for the temp and oil lights to come on together.It could be a dash wiring/circuit board fault,but something must be triggering it.

I'd start with the oil pressure,and go from there.(We are always here to help if you need it!)

By the way,where are you from exactly?

I'd rather push my Alfa than drive a BMW....
Currently in Lagdti's garage:
2004 Saab 9-5 HOT Aero and a 2001 Audi A3 1.8 Turbo
Lagdti is offline  
Sponsored Links
post #7 of 11 (permalink) Old 25th April 2006
Platinum member
Oilyrag's Avatar
Join Date: Jan 2006
Posts: 2,875
Nominated 0 Times in 1 Post
Nominated TOTW/F/M Award(s): 1
Thanks: 19
Thanked 28 Times in 27 Posts
Here is the link to another post that could be relavant.
Just a thought. Regards Oily.

I am not an alcoholic. Alcoholics go to meetings:D "
Currently in Oilyrag's garage:
59 Vauxhall Zaffira 1.6 Life & 1957 Austin A35
Oilyrag is offline  
post #8 of 11 (permalink) Old 26th April 2006
Diamond member
Join Date: Apr 2006
Posts: 161
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 1 Time in 1 Post
the clio warning lights oil & temp come on together when oil light comes up suspect oil pressure switch but have oil pressure checked just in case
Currently in faultman's garage:
1997 renault laguna 2lt
faultman is offline  
post #9 of 11 (permalink) Old 26th April 2006
Let's be carefull out there
chris m's Avatar
Join Date: Jan 2006
Posts: 19,344
Nominated 1 Time in 1 Post
Nominated TOTW/F/M Award(s): 3
Thanks: 3
Thanked 32 Times in 32 Posts
Send a message via MSN to chris m
I have a '94 Clio and the bleed screw is located on the top right of the rad (at the back). Apart from that procedure as per Oilys post. I'll try to post a pic of the location if I can.
Currently in chris m's garage:
2000 Scenic 2.0 16v Monaco, BMW 3 Series, Pug 206
chris m is offline  
post #10 of 11 (permalink) Old 26th April 2006 Thread Starter
Junior Member
Join Date: Apr 2006
Posts: 5
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Lagdti, im from guernsey in the channel islands. Thanks for the advice here people, im stil working on problem keep the advice coming! im going to bleed coolant tomorrow and get a new oil switch to see if thats the problem. I cant see theres any prob with oil itself, i renewed plugs, filters and oil 2 days ago
tryman1978 is offline  

clio , mk1 , oasis

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome