Resetting Flashing Spanner Light - Renault Forums :: Independent Renault forum

Electronics In Car Entertainment (ICE), Sat-Nav, lighting, wiring etc.

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 19th August 2009 Thread Starter
Junior Member
Join Date: Aug 2009
Posts: 9
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Resetting Flashing Spanner Light

Can anyone help me reset the service indicator (flashing spanner) on my 2005 (55 reg) Kangoo 1.5dci?

Just bought the car, serviced when bought but the dealer said they couldn’t get the light to go out & I don’t fancy an expensive tried to Renault to get it fixed …

When I insert the ignition key & turn it I get the flashing spanner with 6 dashes – no indication of any mileage to the next service, so looks like the interval has been reset (sort of) but the spanner still flashes all the time.

I have tried what the manual says, and have scoured these forums and from all the various solution posted have got closest with the following one but come unstuck, as follows :-

Hold in end of wiper stalk (multi-function display button) and turn on ignition. All the dials and whole display lights up (test mode). Release end of stalk, then press again to go through options – CAL A (whatever that is), 50 (which I think refers to fuel capacity), then a trip mileage, then the 6 dashes, then get to the spanner symbol with number 1 then a mileage figure. At this point I press the trip reset button and the display goes back to the 6 dashes and the spanner is still flashing. Tried holding for 10secs etc. but to no avail.

Also tried another method holding in stalk button when on the “fuel range” display but this does nothing at all (can’t hold the stalk in when on the display anyway as this changes the display to the next option …)

Any ideas gratefully received and will be tried…thanks in anticipation
volcano is offline  
  5 Lastest Threads by volcano
Thread Forum Last Poster Replies Views Last Post
Can anyone name this alloy wheel design? Wheels & tyres 5 1385 10th September 2009 11:50 AM
Resetting Flashing Spanner Light Electronics Lagdti 1 5835 19th August 2009 09:54 PM
Disable Kangoo Passenger Airbag Electronics volcano 13 7126 17th August 2009 01:56 PM
Sponsored Links
post #2 of 2 (permalink) Old 19th August 2009
Veteran Member
Technical Supremo
Lagdti's Avatar
Join Date: Dec 2005
Posts: 40,429
Nominated 2 Times in 20 Posts
Nominated TOTW/F/M Award(s): 18
Thanks: 149
Thanked 1,103 Times in 942 Posts
I think all you do is press the wiper button repeatedly until the service indicator comes up,then press and hold the button.This has worked for me in the past,but it sounds like you may have a problem with the system somewhere.

I'd rather push my Alfa than drive a BMW....
Currently in Lagdti's garage:
2004 Saab 9-5 HOT Aero and a 2001 Audi A3 1.8 Turbo
Lagdti is offline  

flashing , light , resetting , spanner , spanner reset

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome