Renault Megane 04 Hatch Card Reader Problem? - Renault Forums :: Independent Renault forum

Electronics In Car Entertainment (ICE), Sat-Nav, lighting, wiring etc.

LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 9th September 2009 Thread Starter
Junior Member
Join Date: Sep 2009
Posts: 2
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Renault Megane 04 Hatch Card Reader Problem?


Got a Renault Megane 04 plate from new. Had various problems over the years but having the Card not Recognised error at the moment. 1 card started getting this error and would not work so started using backup card. About a month later this one started playing up. But I found that if I wiggled the card in the reader it would then recognise it and work. This worked for about 2 months and ended up with the card going in at an angle and having to twist it. The card opened and locked the car fine so no problems with the batteries.

Well eventually that card stopped working as well while I was out. Used my Autoaid subscription for the first time and my Dad found a garage in my town that was a Renualt specialist. I had never used them before. Car got dropped off on the Friday and they told me it would be looked at on Monday. Rang Monday afternoon and got told too busy to look at it so will be the next day.

They ordered a new card reader but that still did not fix the problem. I rang today and they said that they were checking the wiring loom for the ignition to the UPC. Which I presume is the computer. They said that they had noticed some water damage in the UPC. I queried this as I had no other problems with the car apart from the card not being detected.

I asked if it could be that I need new cards but he said that he couldn't test the cards until the loom was fixed. He said that he had even tried another card from a different car in it and that had not put the ignition on! Now as far as I am aware only the correct card will bring the ignition on, is this correct and if so what the hell is he on about?


jonmalco is offline  
  5 Lastest Threads by jonmalco
Thread Forum Last Poster Replies Views Last Post
Renault Megane 04 Hatch Card Reader Problem? Electronics scatz 5 19838 9th September 2009 12:54 PM
Sponsored Links
post #2 of 6 (permalink) Old 9th September 2009
Platinum member
scatz's Avatar
Join Date: Sep 2006
Posts: 12,008
Nominated 0 Times in 4 Posts
Nominated TOTW/F/M Award(s): 5
Thanks: 59
Thanked 331 Times in 300 Posts
Hi Jon,

I can't imagine what he's talking about and I can't see even Renault designing a car that would allow another card to even initiate the ignition??????

I was going to suggest giving the reader a damned good clean but seeing as the reader has been replaced I'm stumped. I can only assume he's right in saying the fault lies beyond the reader itself.........hopefully someone else that has maybe had similar problems can shed some light on the problem.

Currently in scatz's garage:
2004 Subaru Legacy GT Spec B, a 2013 2.0 TDCi Titanium X Sport S-Max and a 2001 Honda NSR125R
scatz is online now  
post #3 of 6 (permalink) Old 9th September 2009
Technical Supremo

Join Date: Feb 2007
Posts: 42,940
Nominated 16 Times in 67 Posts
Nominated TOTW/F/M Award(s): 28
Thanks: 372
Thanked 5,201 Times in 4,712 Posts
Time to take the vehicle to another garage me thinks. They may not be lying but seem on the face of it to be economic with the truth.
Another key definitely won't work - each keycard is individually programmmed when new and then programmed into the car. Additionally it takes specialist equipment to test the card itself and as far as I know such equipment is only available to Renault dealers or a few specialist auto locksmiths.
I would think there is a possibility that the constant twisting of the card due to a duff cardreader has broken something inside the PCB of the card itself.
There is a possibilty of water ingress to the ECU but considering the history outlined my opinion leans towards a broken keycard.

Take the car to someone who knows what they are doing - Caveat Emptor - Buyer Beware
Currently in madnoel10's garage:
Honda Civic 1.4l
madnoel10 is offline  
post #4 of 6 (permalink) Old 9th September 2009
Diamond member
martink's Avatar
Join Date: May 2009
Posts: 436
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 25 Times in 24 Posts
Hi,do you know a renault dealer near you and if so see if you can get the key cards tested,they should have a card reader called a carteclef at workshop reception so the technicians can write service info into them,get them to put your key cards on it and see if it reads anything,if it can't read anything the key cards are faulty and from your description I think the key cards are faulty.
martink is offline  
post #5 of 6 (permalink) Old 10th September 2009 Thread Starter
Junior Member
Join Date: Sep 2009
Posts: 2
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts

Thanks for the replies. The closest Renault dealer is about 20 miles away.

I have spoken to the garage again this morning. I told him that I feel that it is the cards that are faulty. He said that he found it unlikely that both cards had gone at the same time. The thing is I told them when I brought the car in that the first card stopped working a few months before the other one. So not sure if that made a difference to the way he is looking at the car now.

I also asked him if he had equipment to test the card itself. He said that there is a testing procedure for the card when it is put in the card reader and it is connected to the diagonistic machine. It tells you if it detects the card, if it has the right immobiliser codes etc. He said that mine doesn't detect anything. Which made him think the problem was elsewhere. To me this sounds more like a card problem. Is this the way you can detect if the card works?

He also said that he is getting another Megane in today and is going to try my card in that one when connected to the diagnostic machine to see if it picks it up at all, just to say it has the wrong immobiliser codes I guess or if it does not pick it up at all.

He did say that he might have to order in a new card and it might take 5 to 10 days. I asked how much they are and he said 80. I also asked if he can program them and he said they can as they have access to all the imoberliser codes from Renault!

I also enquired how much it had cost so far and he said not much as he has only been on it for about 2 hours. Considering he has had it since late Friday this seems to be taking a while. But at least it shouldn't be a big bill so far.

Thanks again for the comments.
jonmalco is offline  

card , hatch , megane , problem , ranult , reader , reanult , renault

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome