Traffic battery discharging - Renault Forums :: Independent Renault forum

Electronics In Car Entertainment (ICE), Sat-Nav, lighting, wiring etc.

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 27th October 2009 Thread Starter
Junior Member
Join Date: Oct 2009
Posts: 1
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Traffic battery discharging

Hi all.

Would love some help on this one. Have Renault traffic 1.9 on 53 plate and have had trouble with battery discharging very very quickly. Have had battery and alternator changed but has made no difference, in desperation i started pulling fuses and have noticed that if i pull the 70amp fuse (which i think is for glow plugs) the battery does not discharge, but glow plug light comes on dash. The van still starts but i'm assuming only on a warm day if this is the pre heater i've unplugged. Any help would be great. Thanks
Currently in delboy11's garage:
traffic 1.9
delboy11 is offline  
  5 Lastest Threads by delboy11
Thread Forum Last Poster Replies Views Last Post
Traffic battery discharging Electronics hondo 1 1177 27th October 2009 09:59 PM
Sponsored Links
post #2 of 2 (permalink) Old 27th October 2009
Banned User
Curveball Champion
hondo's Avatar
Join Date: Sep 2005
Posts: 30,768
Nominated 9 Times in 16 Posts
Nominated TOTW/F/M Award(s): 10
Thanks: 1,929
Thanked 3,511 Times in 2,879 Posts
Hi Delboy11 I'm going right out on a limb here, because I know bugger all.

But that may not be the fuse for the glow plugs, each GP should show around 0.6 Ohms.

Unless I've got this wrong, using Ohm law 12 divided by .6 = 20 Amps X 4

I doubt a 70 amp fuse would cover the initial shock of 80 amps.

I'm up for correction though

I'm sorry that doesn't help in solving your problem.
Currently in hondo's garage:
1.6 Valve-Matic SR. Red hot, toasty feet.
hondo is offline  

battery , battery drain , discharging , glowplug , pre heater , traffic

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome