Sat Nav & Clock Faults ?? - Page 2 - Renault Forums :: Independent Renault forum

Electronics In Car Entertainment (ICE), Sat-Nav, lighting, wiring etc.

LinkBack Thread Tools Display Modes
post #6 of 6 (permalink) Old 11th November 2009 Thread Starter
Junior Member
Join Date: Mar 2009
Posts: 6
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
not had the battery checked , i'v had a volt meter on it and whilst it was running it was at the top end of 13amp and sat idol it was arould 12.5 amps so i dont thinks it the battery. I'v had no problem with the battery since i gave it a good charge. which was the day before sat nav packed in, so im tempted to think the 'problem' that was starting with the sat nav flattend the battery maybe.
Currently in mikee127's garage:
2004 Laguna 1.9 dci Sports tourer
mikee127 is offline  
Sponsored Links

clock , faults , nav , sat

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome