electronic problem.......pls help - Renault Forums :: Independent Renault forum

Electronics In Car Entertainment (ICE), Sat-Nav, lighting, wiring etc.

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 9th November 2009 Thread Starter
Junior Member
Join Date: Nov 2009
Posts: 1
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
electronic problem.......pls help

can someone please help me as i am slowly losing faith in a car i once loved.....i own an 04 megane 1.9dci privelage....i had to have a complete engine rebuild due to the duel mass fly wheel exploding which wrecked the bottom end starved the turbo of oil etc etc etc....basically the whole rebuild cost me a small fortune..

i then had the car back for two weeks and i started it one day it stalled instantly......the fault on the screen said electronic failure....i had the fuse board replaced.....

the car starts perfectly now but the heater/aircon doesnt blow or the small lcd display doesnt work....also the cigarette lighter doesnt work....the stereo doesnt come on/switch off automatically like before.....also the windscreen washer doesnt work...

all in all my once loved megane is becoming an absolute nightmare

someone please help me
Currently in markandrachs04megane's garage:
2004 renault megane 2 1.9dci
markandrachs04megane is offline  
  5 Lastest Threads by markandrachs04megane
Thread Forum Last Poster Replies Views Last Post
electronic problem.......pls help Electronics Gonescenile 1 747 9th November 2009 02:25 PM
Sponsored Links
post #2 of 2 (permalink) Old 9th November 2009
Platinum member
Join Date: Jan 2006
Posts: 2,637
Nominated 0 Times in 4 Posts
Nominated TOTW/F/M Award(s): 3
Thanks: 48
Thanked 372 Times in 284 Posts
It sounds suspiciously like a blown 10 amp fuse in the glovebox fuse board. It's accessed thru a small hatch in the top of the glovebox.
I'm sure someone else had the same prob lately and this was the cause.
My Scenic did the same a while back. Bloke at the dealership went straight for the fuse ..... said it was pretty common.


I think I have CDO. It's like OCD, but with ALL THE LETTERS IN THE RIGHT ORDER
Currently in Gonescenile's garage:
A wee French toy & a 2010 Honda VFR 800
Gonescenile is offline  
Old 26th November 2009
This message has been deleted by selwonk. Reason: Very helpful!

electronic , problempls

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome