help kangoo speedo fault - Renault Forums :: Independent Renault forum

Electronics In Car Entertainment (ICE), Sat-Nav, lighting, wiring etc.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 17th June 2010 Thread Starter
Junior Member
 
Join Date: Jun 2010
Posts: 26
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 2 Times in 2 Posts
Smile help kangoo speedo fault

Hi people new to this forum! im looking for some help. I recent purchase a cat c kangoo 1.9 diesel which is now on the road and in working order except for the speedo! I have checked the sensor wiring I have 12v on one wire, a good earth and i checked the signal wire which seems to have continuity between the speed sensor end and the dashboard. I have changed the sensor for a new one, no luck. i tested this with a drill to see if the speedo worked and nothing. I tried the dashboard test but this does not work on these clocks. I then went to a breakers yard where i got a new set of clocks with rev counter which was plug and play. did the dashboard test on this and all the gauges worked but still no speedo. i even tried running a direct feed to by pass the signal wiring still nothing. i did notice the wire is spurred of from the white connector block near the battery. this goes to what i think is a central locking unit (i assume it has some kind of door locking system when you move off?). the doors dont appear to lock when moving off thought this may be connected. any help is greatly appreciated.
superkev11 is offline  
  5 Lastest Threads by superkev11
Thread Forum Last Poster Replies Views Last Post
kangoo 1.9d 2000 Engines superkev11 9 1938 26th March 2013 11:10 PM
kangoo 1.9 diesel glow plug relay Electronics mrfixit4u 5 4745 15th November 2011 10:39 PM
1.6 16v kangoo Engines superkev11 1 867 17th October 2011 06:58 PM
kangoo rough running Engines Misty! 2 1439 22nd April 2011 07:57 PM
1.9d kangoo belt squeal Engines superkev11 2 2126 19th March 2011 10:09 PM
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 18th June 2010
Banned User
 
Join Date: Feb 2008
Posts: 1,675
Nominated 0 Times in 9 Posts
Nominated TOTW/F/M Award(s): 3
Thanks: 17
Thanked 139 Times in 131 Posts
Re: help kangoo speedo fault

I guess fault finding non working speedos was more straightforward in the olden days.
As regards your problem, I always thought these modern cars pick up the speed signal from the ABS computer based on reluctor ring average. Are there any ABS problems perhaps?
Currently in tolsen's garage:
Trekka 1.9 DCI, Smart Cabrio Cdi (65 - 85 MPG) & Ford Transit 2.2 Duratorq TDCi
tolsen is offline  
post #3 of 7 (permalink) Old 18th June 2010 Thread Starter
Junior Member
Threadstarter
 
Join Date: Jun 2010
Posts: 26
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 2 Times in 2 Posts
Re: help kangoo speedo fault

hi thanks for the reply it has not got abs so that is out of the question thankfully. should the signal wire pulse a signal?
superkev11 is offline  
post #4 of 7 (permalink) Old 18th June 2010
Banned User
 
Join Date: Feb 2008
Posts: 1,675
Nominated 0 Times in 9 Posts
Nominated TOTW/F/M Award(s): 3
Thanks: 17
Thanked 139 Times in 131 Posts
Re: help kangoo speedo fault

In that case there must be a sensor on the gearbox somewhere. Possibly same location as where older gear boxes had a worm gear for the mechanical drive to speedo. I assume there will be a reluctor ring inside gearbox instead of the worm gear and a sensor similar to an ABS wheel speed rotation sensor. Output from ABS rotation sensor is a sine wave. You said you tested using a drill. Does that mean you have found the sensor and turned something with your drill?
Currently in tolsen's garage:
Trekka 1.9 DCI, Smart Cabrio Cdi (65 - 85 MPG) & Ford Transit 2.2 Duratorq TDCi
tolsen is offline  
post #5 of 7 (permalink) Old 18th June 2010 Thread Starter
Junior Member
Threadstarter
 
Join Date: Jun 2010
Posts: 26
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 2 Times in 2 Posts
Re: help kangoo speedo fault

i turned the spindle of the speed sensor with the drill but that was outside the gear box. so you are possibly suggesting that there is a relucter in the box which produces the signal so its possible its the drive gear thats not working. ie the drill wont make the unit work out side the gear box. thanks for your help
superkev11 is offline  
Reply

Tags
fault , kangoo , speedo

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome