Renault Forums :: Independent Renault forum - View Single Post - Argghhhh

Thread: Argghhhh
View Single Post
post #1 of (permalink) Old 11th May 2007 Thread Starter
Diamond member
vicfisher's Avatar
Join Date: Apr 2007
Posts: 105
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts

I wish I had smaller hands.

Installing new head unit into my '01 Laguna today and hit a few problems:

Lost power to head unit and then noticed that aircon/climate also no workee. Checked fuses by drivers door - what a nightmare, who designed that access, someone with hands the size of a two year old by the feel of it.

Established that the fuse for aircon was ok but still no power to HU or aircon/climate.

Came indoors and trawled through here to find that there is a 'secret' fuse not mentioned in the manual. It's under the ashtray. How could I have been so stupid as to not think of pulling the ashtray out and looking in there for a fuse! Sheeesh!

Trundled back to the car and had another knuckle skinning session trying to get the 'secret' fuse out. It was indeed dead. Put replacement in...... oh, that's right, it's fallen into the guts of the console beyond the reach of any mortal (unless you have an extended digit similar to the one sported by a certain lemur that uses it for digging bugs out of tree bark).

Luckily had another replacement fuse in the garage (up the lane). Put new one in and yeah.... we have power!

Now that all was working, the next task was fitting all the cabling in. Hmmm... bit like trying to force eight pounds of spaghetti through the neck of a milk bottle. Anyway, losing yet more knuckle skin took my mind off murderous thoughts. Eventually, after removing 'cubby bin' from above HU slot, I got everything sorted and tidied.

One cup of tea later and all is calm in my world and I have my new(ish) HU working nicely.

One point though. I have wired it up with the required adapter for remote stalk and display. On the dash display, it just shows 'JVC' but doesn't display radio station info or CD track info. Is this normal? It does, however, show when you're changing volume. Any advice on that would be appreciated.

I'm now off to patch up the lost skin.

"I'm not easily distrac... ooh ooh look, shiny thing"
Currently in vicfisher's garage:
Citroen C4 Picasso VTR+ 1.6HDi EGS
vicfisher is offline  
  5 Lastest Threads by vicfisher
Thread Forum Last Poster Replies Views Last Post
My Lag has gone General Chat vicfisher 9 1992 17th November 2009 02:03 PM
Otto General Chat 4 1176 3rd November 2008 09:46 PM
Workshop manual for 3.0 V6 Engines N7Qauto 38 5945 15th July 2008 03:58 PM
Stoopid dash question Electronics madnoel10 4 1199 24th May 2007 11:25 AM
Scratch repairing Bodywork DEEJAY 225 8 1901 17th May 2007 09:59 PM
For the best viewing experience please update your browser to Google Chrome