Renault Forums :: Independent Renault forum - View Single Post - Is this a fuse?

Thread: Is this a fuse?
View Single Post
post #29 of (permalink) Old 12th May 2007
Junior Member
Join Date: Jan 2007
Posts: 3
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Question skipped eurovision worked on my heater blower

Hi it seems like we got the same problem U and I

So far I have changed the
Heater blower motor (no result)

Heater control panel (no result, from the breaker)

The relay you asked about was it placed above the heater fan? (behind passenger airbag/glovcomp.)
Then it is for the fan motor it is circuit over fuse F37 (placed under the normal fusebox) this fuse is for the AC checked mine was ok... measured voltage on the th realy and it varies fron 3-9 volt, soo I connected a freash wire from battary with 12 volts and the motor twiched but the releay switched of and on... might be some problem with the motor since I put that in before I changed the controll panel (wich when changed had burned component in it) so i might have wrecked the new motor... My next try is changing relay (since its cheap) but my best guess is that there is somthing wrong with the AC since ther is a voltage drop in that circuit. dont want to repair a -97 for AC but i would like the fan to work so Im looking for some workaround...

BTW my lcd on the control panel is blank as well, how is yours?

I would recomend trying to change the realay (they are cheap) just bring the old one to the shop...

I will sign in tomorow evning after or while working on it and let you know how things are going... any news from you let me know....
Currently in hw's garage:
Renault Laguna rxe 2.0
hw is offline  
For the best viewing experience please update your browser to Google Chrome