Renault Forums :: Independent Renault forum - View Single Post - Couple of niggles... looking for advice

View Single Post
post #3 of (permalink) Old 17th May 2007 Thread Starter
x Wilco x
Junior Member
Join Date: Mar 2007
Posts: 15
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Sorry, having a few issues posting - will try again...

Hi guys, I have a couple of niggles with my Clio mk2 (53 plate) that I really need to address and before I start poking around thought I would ask for some advice (do's and don'ts etc).

1) Hazard light switch, on panel above radio, will not pop out when pushed. If I keep on pushing and wiggling it does eventually pop out. Once out, it pops back just fine but then won't pop out again! Wanna explore if it is sticking or if needs replacing etc but can I just pop out the panel it is sat in etc to have a look?

2) Rear, nearside, bank of lights are suffering a loose connection. Reverse light works on occassions and indicator does the same (causing x2 flash). Bulbs all fine and sitting in sockets ok, problem seems to be with wires going into the bank of lights - if I wiggle the wires they correct themselves etc... How do I tighten/secure the connections to stop this intermittent issue? The wires seem to go into a black connection before attaching to bank of lights - can I just pull this off to have a look etc or is this not a good idea???

Obviously don't want to make problems worse, at this stage, by going in like a bull in a china shop and fiddling around so any advice would be greatly appreciated...

Many thanks in advance...
Currently in x Wilco x's garage:
2003 Clio Dynamic 1.4 16v
x Wilco x is offline  
For the best viewing experience please update your browser to Google Chrome