Renault Forums :: Independent Renault forum - View Single Post - Renault Laguna II - Phase 1 - Engines - Poor starter in cold weather - 2.2DCi MAF Sensor

View Single Post
post #1 of (permalink) Old 29th December 2005 Thread Starter
Join Date: Sep 2005
Posts: 85
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs down Renault Laguna II - Phase 1 - Engines - Poor starter in cold weather - 2.2DCi MAF Sensor

My Renault Lag 2 2.2 DCI takes ages to get going when its really cold weather. It fires, splutters, then dies. Eventually (after up to 15 tries) it will go. If the battery is not dead by then!

Most obvious cause to me will be the glow plugs? I know the MAF needs replacing though, but surely this wouldn't cause it not to start?

However its been in the garage for 2 days and they say the glow plugs and pre heater are all ok.

They suggested an air leak in the fuel system! However it doesn't leak fuel that I can see and its not a problem above about 8 degs, only when its frosty and has been out all night. Its fine through the day then, even if not used for 8 or 9 hours while in work.

Any ideas anyone cos I'm stumped!

By the way it wasn't a renault garage that looked at it.

bonerp is offline  
  5 Lastest Threads by bonerp
Thread Forum Last Poster Replies Views Last Post
2.2 DCi hesitation problems Engines v00d0019 10 2616 8th June 2006 12:18 PM
PC turns off! Computer Club Lu 7 1665 26th May 2006 08:02 PM
Hesitates at 2000rpm 2.2Dci Lag Engines vit77 4 1436 24th May 2006 08:10 AM
May have a solution to gearbox woes Cars & motoring SportTourer 1 1101 26th January 2006 02:24 PM
Renault Laguna II - Phase 1 - Engines - Poor... Laguna domini 10 4203 29th December 2005 04:28 PM
For the best viewing experience please update your browser to Google Chrome