Renault Forums :: Independent Renault forum - View Single Post - Renault Laguna I - Phase II - Few Niggling problms

View Single Post
post #1 of (permalink) Old 28th May 2007 Thread Starter
Junior Member
Join Date: May 2007
Posts: 5
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Renault Laguna I - Phase II - Few Niggling problms

Hi All

I have been roped into helping my ma sort out her new shopping trolley. (1999 V - Laguna Phase II RXE)

I have noticed a couple of problems that I would like to sort out.

OK, first problem is Engine, or more specifically the engine type.

The block is stamped F3R K6 and the first digits of the vin are OVF1B56L

Here is the offending article. I think it's the 8v variety.

The insuarnce documentation states 16v. Is there any way of verifying the original fitment? I am thinking maybe an engine swap at some point?

Problem's 2,3 and4 are all related.

The Automatic climate control doesnt light up, nor does the odometer on the instrument panel. I assume they are Osram twist fit bulbs? Any specific type I should get?

The Haynes mentions removing the steering wheel to access the instrument cluster...surely not!?

Also, the instrumentation panel dims to the point of zero visibility when the headlights are switched on.

Any ideas?

I have done a few searches, but I can't find the right combination of words for my problems.

thanks in advance

spookylee is offline  
  5 Lastest Threads by spookylee
Thread Forum Last Poster Replies Views Last Post
V reg Laguna 2.0 RXE - Dash failure Electronics Lagdti 1 1260 29th May 2008 05:29 PM
Releasing latching switches in ISO con Electronics spookylee 2 918 28th May 2007 11:17 AM
Renault Laguna I - Phase II - Few Niggling problms Laguna leroy 3 2536 28th May 2007 10:39 AM
For the best viewing experience please update your browser to Google Chrome