Renault Forums :: Independent Renault forum - View Single Post - Can't get the drum back on??!!!

View Single Post
post #8 of (permalink) Old 28th September 2014 Thread Starter
Junior Member
Join Date: Aug 2014
Posts: 10
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 7 Times in 5 Posts
Re: Can't get the drum back on??!!!

Good news! The drums and on and the wheels are on, and everything works (brake bleeding excepted!).

So, the problem. The auto adjuster looked very much as though it was back on its stop. The cylinder leak had coated everything in a paste of fluid and brake dust. I'd cleaned it as much as I could, but in fact this maksed the issue. When the spring had been put on the adjuster screw it was up on the threads, not at the base. Over time the thread had rolled over a bit about 3 mm from the real end stop. When it wound freely and then stopped I thought that was it. It wasn't. With a couple of pairs of grips I wound the adjuster back further, remaking the thread. With that out the way and the springs finally in the right places, and a bit of encouragement, the drum slipped on. Hurrah! The handbrake is working just great, (5 clicks) and once the circuit is bled I reckon we are home and dry. Phew!
Currently in NeilParkin's garage:
Kangoo van 1.5dci
NeilParkin is offline  
The Following 3 Users Say Thank You to NeilParkin For This Useful Post:
hondo (28th September 2014), Phil48 (28th September 2014), Renoir White (28th September 2014)
For the best viewing experience please update your browser to Google Chrome