Renault Forums :: Independent Renault forum - View Single Post - Disconnect battery... ECU reset?

View Single Post
post #1 of (permalink) Old 8th January 2006 Thread Starter
Junior Member
Join Date: Jan 2006
Posts: 3
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation Disconnect battery... ECU reset?


I have been looking at buying a megane 1.9 TDi RT Sport, and on the test drive I noticed that an engine light comes on when your foot is not pressing the gas. The light is red with a horizontal zig-zag pattern on it. The light turns off when you apply the pedal. The engine also seems to idling quite high at 1500rpm but I have never purchased a diesel so I don't know if this is normal!
The seller assures me these two things are related-- because "the battery has been disconnected for a while, and the ECU needs to be reset ("zapped" in his words) by a Renault garage."
I personally find it hard to believe that disconnecting the battery would cause this kind of problem, people have to disconnect the battery all the time to do bits and bobs to their cars! But having said that maybe an extended period of disconnection could cause its capacitors to discharge and for the ECU to reset to default.

Does anyone else have an experience of this kind of problem after disconnecting the battery- or is my man lying to me?

Any idea of the kind of cost I would (inevitably) get charged by the renault garage?

datimms is offline  
  5 Lastest Threads by datimms
Thread Forum Last Poster Replies Views Last Post
Disconnect battery... ECU reset? Electronics kenny 6 10055 8th January 2006 10:01 AM
For the best viewing experience please update your browser to Google Chrome