Renault Forums :: Independent Renault forum - View Single Post - Wiper woes

Thread: Wiper woes
View Single Post
post #2 of (permalink) Old 24th June 2007
Still a Petrolhead but also like diesel
Truckbusuk's Avatar
Join Date: Apr 2006
Posts: 2,311
Nominated 0 Times in 2 Posts
Nominated TOTW/F/M Award(s): 2
Thanks: 0
Thanked 17 Times in 17 Posts
Hi pw1962, assuming that the blades and mounts are in good condition and your not using replacement blade inserts, or washing up liquid in your screen wash the first thing to check is that the glass is clean as a build up of silicone is usually the culprit, try cleaning the glass with vinegar, meths or use a good quality screen wash neat on a cloth and clean the glass.

If thats no joy the chance is the wiper arm(s) are slightly bent so the blade is not being presented perpindicular to the glass, adjust them using an adjustable spanner across the flat part of the arm and twist so the blade looks like its at the correct angle, you might need to try this a few times to get it spot on.

Its usually caused by automatic car washes bending the arms ..... use a good quality screen wash or an additive called "clearalex" which will keep the glass free of any build ups .... hopefully problem solved.

hope it helps

Why is it the older I get .... the better I think I was ?
Currently in Truckbusuk's garage:
Clio2 1.4RT Phase1(VF1BB0S) + Volvo XC90 SE Lux D5 Geartronic
Truckbusuk is offline  
For the best viewing experience please update your browser to Google Chrome